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Chapter 1

Introduction

CODE V is a general-purpose optical design and analysis program that can be used 
for many types of optical systems. In recent years, there has been an interest in the 
design and analysis of discrete components for fiber optical telecommunication 
systems, including devices such as isolators, couplers, and wavelength-division 
mulitiplex (WDM) filters. CODE V is an excellent tool for designing such systems, 
whether they contain basic components such as lenses, mirrors, prisms, and grat-
ings (including micro-optical components), or additional features such as coatings 
and polarizing elements.

This introductory guide describes the detailed steps necessary to define, optimize, 
and analyze a ball lens coupler and a grating-based WDM de-multiplexor system. It 
also provides examples of additional telecom components. These examples serve as 
a starting point for working with these types of components.

Check the Optical Research Associates Web site http://www.opticalres.com for 
additional example macros or later editions of this guide. You can also obtain 
information on these features via e-mail by addressing requests to 
service@opticalres.com.

http://www.opticalres.com
mailto:service@opticalres.com
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Questions and Answers About CODE V and Photonics 
Systems

What do you mean by photonics systems?
In this guide, the term photonics systems is used more or less interchangeably with 
optical telecommunication systems. This includes a number of optical devices that 
typically interface with fiber optics, such as connectors, multiplexors, isolators, 
couplers, and filters.

Where does CODE V fit in with photonics systems?
CODE V was originally developed as a tool for designing and analyzing image-
forming optical systems such as microscopes, cameras, laser scanners, and 
scientific instruments. Many photonics systems have components that are 
fundamentally similar to conventional image-forming optics. CODE V is a 
powerful tool for working at the optical component level, but it does not have 
features related to complete systems, networks, etc.

What are the advantages of using CODE V for this type of design 
work?

CODE V can model an extremely broad range of system types. It also provides 
powerful optimization and analysis capabilities, as well as a robust macro language 
for extending its calculations. 

CODE V can handle systems with many surface types, diverse materials (including 
gradient index), general diffraction gratings, multi-wavelength systems, 
polarization properties (including birefringence), multi-layer coatings, and even 
user-defined properties. It provides analysis options such as diffraction beam 
propagation (BPR), diffraction-based evaluations including polarization effects 
(e.g., point spread function and encircled energy), and many types of geometrical 
optics-based calculations. 

CODE V also provides a special feature for calculating diffraction-based coupling 
efficiency (also known as insertion loss). This calculation is normally based on the 
standard diffraction point spread function, which includes the effects of polarization 
and coatings. It is also possible to calculate coupling efficiency by importing data 
from the more rigorous beam propagation option (BPR), although, in this case, 
polarization and coating effects are not included.
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How do you model optical fibers in CODE V?
In most cases, the optical fibers themselves are not modeled in CODE V, and 
usually do not need to be modeled, because CODE V is typically used to design 
components that interface to or from optical fibers. For this, you need a way to 
define properties of the light emerging from a fiber that is then processed by the 
device you are modeling. For certain analyses, such as coupling efficiency, you also 
need to define the input properties of a fiber. CODE V has these capabilities.

CODE V also has a feature called non-sequential surface modeling that can be used 
to model straight segments of certain types of fibers. This type of model is useful 
for some special purposes, but is not normally used in the design of typical 
photonics components.

Can CODE V model integrated optics or waveguide-type systems?
Not directly. CODE V is used to model discrete components consisting of such 
devices as lenses, prisms, mirrors, filters, gratings, gradient index rods, and 
polarizing elements. Integrated optics is the domain of other software packages, 
although it is possible to take the output of an integrated device (in the form of the 
complex amplitude distribution) and use this as the input to the beam propagation 
calculation in CODE V. There is a feature available in Beam Propagation (BPR) for 
importing a complex amplitude file in a special format, and a macro is supplied for 
exporting complex field data from CODE V. Optiwave (http://www.optiwave.com) 
is the first company to support this feature in their guided wave software, although 
the format is documented and may be usable with other software.

What about optical coatings?
CODE V includes a coating design and analysis module that can be used to define 
and even optimize multi-layer coatings. Although it is a powerful utility, its design 
features are not as extensive as those of certain dedicated coating design programs, 
because CODE V is intended to be used primarily for optical system design, not 
coating design. After a coating prescription is defined and saved in a file, the 
coating can be attached to any surface, where it will properly affect the polarization 
state and transmission of rays traced through it. Polarization can be very important 
in certain diffraction analyses, including point spread function and insertion loss 
calculations.

http://www.optiwave.com
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What analyses can CODE V perform that apply to photonics 
systems?

CODE V can perform geometrical calculations such as simple ray tracing, spot 
diagrams, and encircled energy, which are useful in the early stages of component 
design. To evaluate system performance, CODE V uses the diffraction point spread 
function (PSF) or, more often, the coupling efficiency (CEF), which is derived from 
the PSF. CODE V macros allow you to study CEF vs. wavelength, which is 
important for WDM systems. You can also use the beam propagation feature (BPR) 
to examine the amplitude and phase of a beam anywhere in the system. BPR is a 
powerful feature, but it requires careful attention to issues of sampling to get the 
most accurate results. Tolerance analysis is also available.

What is tolerance analysis, and why is it important?
Tolerance analysis refers to the study of how a system performs when it is 
constructed with manufacturing errors within a specified range; these are the 
tolerances. Simulating how a system performs with errors in construction is 
essential for evaluating whether or not the design is truly practical. CODE V has a 
number of tolerance methods available, including the ability to tolerance on 
coupling efficiency, on user-defined quality measures, and even with user-defined 
tolerance parameters. The effects of assembly-time adjustments (known as 
compensators) can also be simulated.

Tolerance sensitivity is a major driver on the cost of manufacturing any optical 
device. As photonics systems become more complex and handle more closely 
spaced channels, the ability to perform tolerance analysis becomes even more 
important.

What can CODE V do to optimize photonics systems?
CODE V has a powerful optimization engine called AUTO (for automatic design). 
This feature systematically varies system parameters to reduce the size of a 
specified “error function” that correlates with image quality. Default error functions 
based on spot size or RMS wavefront area are normally used at first, but user-
defined error functions are also possible, and a single mode-profile command can 
be added to AUTO input to define a coupling efficiency error function. You can 
optionally account for Gaussian beam spreading in coupling efficiency optimization 
by selecting an additional command. CODE V’s ability to precisely control 
boundary conditions (i.e., constraints) is unmatched in the industry.
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Chapter 2

Fiber Coupling with a 
Ball Lens

This chapter uses a very simple pre-defined optical system to quickly demonstrate 
the photonics modeling features of CODE V, including coupling efficiency, optimi-
zation, and beam propagation.

Contents

Using the New Lens Wizard .....................................................................................6

Calculating Coupling Efficiency.............................................................................13

Optimizing the Lens................................................................................................18

Using Beam Propagation Analysis .........................................................................21

Calculating Coupling Efficiency from Beam Propagation .....................................26
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Using the New Lens Wizard
The New Lens Wizard helps you set up new optical system models, starting with 
sample lenses, a patent database, your own collected “favorites,” or a blank lens. In 
this procedure, you will start with one of the supplied sample lenses: a ball lens. A 
ball lens is a small glass sphere that can be used to couple the output of one optical 
fiber into another. Although this is a very simple lens, it provides a useful 
demonstration of various design techniques for optical telecom systems, which you 
can apply to more complex systems.

Defining the Ball Lens with the New Lens Wizard
Before you can try this example, you need to install and start CODE V. We assume 
that CODE V is already correctly installed and that you know how to launch the 
program from the Windows Start menu.

1. Start CODE V.

2. Choose the File > New menu to launch the New Lens Wizard.

If the New Lens Wizard does not launch, choose the Tools > Preferences menu, 
and be sure the Use Wizards checkbox is checked on the UI tab.

3. Click the Next button to bypass the first screen in the New Lens Wizard.

4. In the second screen in the New Lens Wizard, click the CODE V Sample Lens 
button (the default), and click Next.
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5. Click on the first line of the spreadsheet to select the following lens: 
cv_lens:ballcouple.len

The New Lens Wizard will show you a picture of the selected lens.

6. Click Next to go to the Pupil screen in the New Lens Wizard.
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The pupil type and size determine how much light is accepted by the optical 
system. In photonics systems, this is normally specified as numerical aperture, 
which is the size of the cone of light emitted by the input fiber or other source. 
There is additional data that defines the intensity distribution or apodization of 
the pupil. This is a Gaussian profile whose properties are set by the output char-
acteristics of single mode fibers used as input (lasers are also approximately 
Gaussian).

7. Click Next to accept the displayed data.

The Wavelengths screen in the New Lens Wizard is displayed.

The Wavelengths screen has only a single value: 1550 nm. Wavelengths are 
always expressed in nanometers (nm) in CODE V (1550 nm = 1.55 microns).
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8. Click Next to accept the single wavelength definition and go to the Reference 
Wavelength screen.

The reference wavelength is used to trace the reference rays, a special set of rays 
used for defining default apertures, first order calculations, lens drawings, etc. 
In this case, there is only one wavelength anyway, but many systems use multi-
ple wavelengths.

9. Click Next to accept 1550 as the reference wavelength and go to the Fields 
screen.

The term field refers to the field of view of an optical system. For systems with 
a finite object distance like this one, field is usually expressed as object height. 
The object in a fiber system is essentially a point source that is nominally on the 
axis of the input fiber. This defines the lateral (x,y) positioning of the input fiber 
with respect to the optics. The longitudinal (z) position is defined by the object 
distance.

10. Click Next to accept (0,0) as the object coordinate.

11. Click Done on the final (“Congratulations...”) screen of the New Lens Wizard.

This lens is now ready for lens pictures, analysis, optimization, and more.

Looking at the Lens Data
The lens data is made up of two major parts, System Data and Surface Data. You 
have seen some of the System Data in the New Lens Wizard (pupil, wavelength, 
and fields). Another important System Data entry is pupil apodization. For the ball 
lens, a Gaussian intensity distribution is applied to the pupil, which simulates the 
output from an SMF-28 fiber. You will learn more about this, and other System 
Data entries, later. Surface Data is displayed in the Lens Data Manager (LDM) 
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spreadsheet window and in the Surface Properties window (Lens > Surface 
Properties menu). The LDM spreadsheet is shown below, along with the menu bar 
and toolbars that are used to run the various program features (your toolbar may not 
look exactly like this one, which has been customized through the Tools > 
Customize menu).

Surface data consists of curvature or radius of curvature, thickness to the next 
surface, glass or material, apertures, and a few other parameters. Still other 
parameters are available in the Surface Properties window. One thing to notice in 
the LDM spreadsheet is that some numbers have small letters next to them. These 
are called status indicators (see “Status indicators in spreadsheet cells” in the online 
help for details). Some status indicators are for solves (S); solves are values that are 
set automatically by CODE V to meet a specified condition (these cells are shaded 
gray because you cannot directly edit these solved values). The V status indicator 
on the image surface thickness (defocus) indicates a variable for optimization.

This numerical data is very useful and important, but a picture always makes things 
a bit more clear.

Generating a Lens Picture
There are a number of ways to make lens pictures in CODE V. The main lens 
drawing feature is called View Lens, and this is found on the Display menu. There 
are also several tools on the tool bar for making quick lens pictures, though these 
are set up to draw from the first surface to the image, and in most photonics 
examples, you will want to draw from the object surface. This is not a big problem.

1. Choose the Display > View Lens menu.

This displays the View Lens dialog box, where you can set up and run the 
VIEW option. There are multiple tabs for the many settings that are possible 
with the VIEW option. For now, you only need to change the surface range.
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2. Double-click the first cell in the first row of the Surface span for each position 
spreadsheet, and choose Object.

3. Click OK to run the VIEW option.

The lens picture is displayed in a tabbed output window (TOW). These output 
windows always have a text tab and may have one or more graphics tabs, as this 
one does. Keep this window open (you can resize and move it if you like). If 
you change the lens, you can re-run the picture with the current settings by 
clicking the Execute/Recalculate button. 
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You can also change the settings with the Modify Settings button , which 
appears on each option-generated TOW (macros can also display in TOW's, but 
these do not have a Modify Settings button, only the Execute/Recalculate 
button).



CODE V Photonics Modeling Guide 13

Chapter 2 Fiber Coupling with a Ball Lens

Calculating Coupling Efficiency
There is certainly more to learn about how a lens is defined in CODE V, and we 
will go into more details in the next few chapters. But since this simple lens is 
intended to couple light into a single-mode fiber, you may be curious about how 
well it can do this. CODE V has a feature called Fiber Coupling Efficiency (CEF) 
just for this purpose.

CEF is a diffraction-based calculation, meaning that it accounts for the wave nature 
of light, and not only geometrical aberrations (it can even include polarization 
effects). By default, CEF calculates the diffraction point spread function (PSF) and 
determines the overlap integral of the PSF with the mode profile of the output fiber. 
This can be defined in several ways, most commonly as a Gaussian function. There 
are several other ways to define the input to the CEF calculation, and you will use 
the Beam Propagation method at the end of this chapter.

Defining CEF Input
1. To define the fiber position, choose the Lens > System Data menu, and click 

Fiber Location in the System Data window’s navigation tree.

2. Choose Fixed for the fiber position (Location field), as shown below.
.

Fixed at X=0, Y=0 is actually the default, but it’s good to check this. The other 
method, compensated, aligns the fiber with the chief ray, or center ray, for each 
field. This would not make a difference for an on-axis case like this, but in other 
systems, this can be an important choice.

3. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu.

This opens the Fiber Coupling Efficiency dialog box. You will change settings 
on most of the tabs in this dialog box before clicking OK to run it.
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4. On the Fiber Specs tab, make sure the value for the fiber Gaussian mode radius 
is 0.0052 mm. This is the default value for this field.

The fiber specification is for the output fiber (i.e., the fiber that light is going 
into). Remember that the input fiber characteristics were modeled using a point 
source with Gaussian apodization of the pupil.

Note that there are other methods for defining the single mode for coupling cal-
culations, but Gaussian is most typical, and 0.0052 mm is a value typical of 
common fibers such as SMF-28 at 1550 nm.

5. Click the Beam Definition tab.
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The default ray trace method is a good choice in many cases. This means that 
the program traces rays through the lens and calculates insertion loss based on 
this. Other choices on this tab involve Gaussian beam tracing or importing the 
data from another option (you will do this with beam propagation data at the 
end of this chapter). For now, no changes are needed.

6. Click the Computation tab, and select the Decibel Scale checkbox in the 
Output controls area.

You may need to change the FFT grid size or focal plane increment for some 
systems to get good sampling, though the defaults are usually pretty good. You 
need to make a run first to see if changes are needed (e.g., if the focal plane 
increment is large compared to the mode radius, results will not be good).

Decibel units for insertion loss are most common in telecom applications, so 
this is a useful feature in CEF. The default is fractional coupling efficiency 
values unless you select the Decibel Scale checkbox.

7. Click the Sensitivity Analysis tab. Enter 0.005 for the maximum value for both 
X and Y displacement, and enter 6 for the number of values as shown below.
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You don’t really need to do sensitivity analysis now, but it’s easy and instructive 
to do so. This tab allows you to analyze the effects of errors such as misalign-
ment (this case), tilt, or wedge in the output fiber. 

Note that this sensitivity or error analysis applies only to the placement and 
properties of the output fiber. Errors in the optics themselves are handled with 
tolerance analysis; see Chapter 5 in the CODE V Introductory User’s Guide for 
more information about tolerancing.

8. Click OK.

The Text tab of the Fiber Coupling Efficiency output window always includes 
tabular data on the coupling efficiency as well as auxiliary information on the 
number of rays traced, the alignment of the fiber, etc.
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If sensitivity analysis is specified, you can also get graphical output showing the 
coupling efficiency as a function of the error parameters, as shown below.

Coupling efficiency can also include polarization effects, which will then con-
sider the effects of coatings on glass surfaces (CODE V assumes a ¼-wave anti-
reflective coating of MgF2 on all glass surfaces, unless this is deleted or 
replaced with a multilayer coating). Although CEF is calculated only in the ref-
erence wavelength, there is a supplied macro (plotwl.seq) that allows you to 
plot CEF as a function of wavelength. This will be used in a later example.
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Optimizing the Lens
There is not a lot of optimization you can do with a ball lens of a particular size. 
Changing the radius and glass will make a difference, but once these are fixed, the 
only remaining variable is the longitudinal (z) position of the output fiber. This has 
already been optimized in this example, but that’s easy to change. You can zero out 
the image surface thickness value, which is used as a defocus adjustment. You can 
then use Automatic Design (AUTO) to refocus it.

Looking at Variables
In the LDM spreadsheet window, do the following to create a variable:

• Change the thickness of the Image surface to 0 as shown below, then press the 
Tab or Enter key (or click in any other cell) to enter this data. 

Notice the small V displayed next to this value. This indicates a variable, which is a 
parameter that is allowed to change for optimization purposes. (Note that this is the 
only variable in this lens—some lenses have many variables, but, in this case, you 
are only making a small adjustment to a finished design, albeit a simple one.) You 
can right-click on any cell to display a shortcut menu of settings that apply to the 
cell. Two common settings are Vary and Freeze.

If you re-run the Fiber Coupling Efficiency now, you will find that the nominal 
value (i.e., no decentration errors) is about -3 dB, compared to about -1 dB when 
focused. You can get back to this value with optimization.

Tip:  Don’t close the output window for coupling efficiency; you will need to re-
run it and modify its settings later. However, you can move, resize, or minimize the 
window.
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Defining Automatic Design Input
1. Choose the Optimization > Automatic Design menu.

The Automatic Design dialog box is displayed.

On the first tab, Error Function Definition and Controls, you can choose 
from several optimization quality criteria or “error functions” depending on 
your application. Transverse ray aberration is most common and works best 
when your design is very far from a reasonable solution. In this case, fiber cou-
pling efficiency is the best choice, since the ball lens coupler is only out of 
focus.

2. Choose Fiber Coupling Efficiency from the Error Function Type dropdown 
list.

3. Click in the first row of the Fiber Mode Radius spreadsheet.

This inserts a mode radius of 0.0052 (the default value). There are many other 
AUTO inputs that will be important for later examples, but in this case, this 
entry is all you need.

4. Click OK to run AUTO.
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Optimization Output
When AUTO is run, a tabbed output window is displayed with a Text tab that 
contains the cycle-by-cycle report of AUTO's attempt to improve this lens by 
varying the defocus term that you set to zero. The Error tab, which can contain 
standard warnings as well as error messages, is also displayed (its contents are 
nothing to worry about for this example).

The final optimization cycle is shown. The defocus value (your only variable) is 
about -0.14 mm (THI for the IMG surface—the minus sign indicates a shift of the 
fiber towards the ball lens). The error function (ERR.F.) has improved (become 
smaller; zero is best). It started out around 2.4 when you deliberately defocused it, 
and got down to around 1.0 in 8 cycles. AUTO stops when the improvement 
between cycles gets too small (there are other ways to control AUTO as well).

If you re-run CEF now, you should find that the original value of -1 dB or slightly 
below this value for the nominal coupling efficiency has been restored. The defocus 
and CEF values may be a little different from the earlier values due to the likely use 
of a different DEL (ray grid spacing) in AUTO.
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Using Beam Propagation Analysis
We are covering a lot of ground in this chapter! Beam propagation is one of the 
newest and in some ways most advanced features of CODE V. It is especially 
important in systems where the size of the beam is fairly close to the size of the 
optical elements, which is usually the case in fiber optical components.

Why BPR Is Different from Other Diffraction Analyses
Beam propagation (BPR) is different from other diffraction analysis methods in 
CODE V. In PSF and CEF (which uses PSF data by default), the program assumes 
that all diffraction takes place at the exit pupil of the system, with a pupil shape and 
position derived from ray tracing.   BPR also uses ray tracing, but it converts back 
and forth between a wave and a ray representation of the beam. This means it can 
handle diffraction effects anywhere in the system, not only at the exit pupil. In 
some situations, BPR and PSF will give almost identical results, while in others, 
BPR is the only accurate calculation (e.g., with a diverging Gaussian beam in a 
long air space between optical elements and/or fibers).

BPR has limitations, such as not including polarization effects (important in some 
systems). It also requires care to be sure there is enough sample resolution for 
accurate results at all surfaces. In spite of these points, BPR is the most accurate 
way to analyze many photonic systems. Please read the BPR section in Chapter 19 
of the Reference Manual; it has a lot of useful advice as well as examples.

Defining BPR Input
1. Choose the Analysis > Diffraction > FFT Beam Propagation menu.

The FFT Beam Propagation dialog box is displayed with the Computation 
tab in the foreground. On the Computation tab, you can designate the range of 
surfaces to apply beam propagation methods (ray tracing is used for other sur-
faces, and is often accurate enough). 

2. Click in the first row of the Propagation Method spreadsheet, and select 
Object as the Start Surface.
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The Automatic method, which is inserted by default, means that BPR decides 
which propagation method to use for most accurate results based on beam size 
and other factors. Default computation parameters are acceptable for this exam-
ple.

3. Click the Input Beam tab, select the Gaussian Beam button, and enter 0.0052 
for the Gaussian beam half-width in both X and Y directions.

This defines a Gaussian beam for the input. BPR does not pick up Gaussian 
apodization from the LDM, when the beam is defined here. This is a special, 
pre-defined case of the more general amplitude and phase distributions that 
BPR uses to define starting beams.

4. Click the Output Controls tab and select Complex Amplitude in the first row 
of the Worksheet Buffer Output spreadsheet. Accept the defaults for other 
parameters such as buffer number (1).
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This is the method used to export final BPR amplitude and phase data in a form 
that coupling efficiency (CEF) can import and use for more accurate CEF calcu-
lations. CEF can import the BPR data you are saving in buffer 1, which is essen-
tially a tab-delineated text file.

5. Click the Color Display tab and select the Color display checkbox.

You can accept the defaults for other parameters including surface numbers 
(only on the image surface for input to CEF). This will add a color raster plot at 
the image surface to the default output. 

6. Click OK to run BPR.

As with other options, graphical and text output displays in a tabbed output win-
dow (TOW).
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BPR Output
BPR is unusual among CODE V options in that it can produce its output on any 
designated surface. Most options only produce final results on the image surface. In 
many cases, such as the current example, you only want data on the image surface, 
but you may sometimes want intermediate phase or amplitude data for diagnostic or 
other purposes.

The text output is reported for every surface. Diagnostic information tells you about 
the position and direction of the beam, as well as which propagation method is 
being used there. Beam radius information is determined by fitting to a Gaussian 
and displaying 1/e2 values. The summary table is most useful.
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DSP (raster display) graphics give you a visual impression of the beam intensity. 
Be sure to note the scale of the enclosing box.
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Calculating Coupling Efficiency from Beam Propagation
Now that you have done a beam propagation analysis and saved the complex 
amplitude in a Worksheet Buffer, you can run CEF and import the BPR data for a 
more accurate calculation of coupling efficiency. (If you closed the CEF output 
window, go back to the Coupling Efficiency section on page 13 and re-do the steps 
there to regenerate the output window).

In Beam Propagation (BPR), you directed output to buffer 1 (B1). Buffers are data 
structures used mainly by macros, but also used in some options to preserve grids of 
data for additional processing. There is currently no spreadsheet display of the 
Worksheet Buffers, but you can use a command to check buffer status. 

• Type BUF? in the Command Window and press Enter.

This shows that the buffer exists and that it has 148 rows and 256 columns. The 
BPR grid was 128 x 128, but this is complex data, so each value has two 
components (hence 256 columns). The 148 rows come from 128 complex data 
value rows plus 20 header data rows.

Note:  If you plan to run a second BPR run that writes to a buffer for export to CEF, 
BE CAREFUL. BPR appends the new data to the buffer so you must use the 
command BUF DEL B1 (or B2, B3, etc. depending on what you used) to delete the 
buffer before export to CEF. If you do not, CEF will use the first valid data it finds 
in the buffer, which will be the “old” data. Another option is to direct the new 
calculation to a different buffer, such as 2.



CODE V Photonics Modeling Guide 27

Chapter 2 Fiber Coupling with a Ball Lens

Importing BPR Data into CEF
Follow this procedure carefully and be sure that you have only one set of BPR data 
in buffer 1, as mentioned in the note above.

1. Click on the Modify Settings button  in the Fiber Coupling Efficiency 
output window.

All the settings will be the same as before, except for the source of the data.

2. Click the Beam Definition tab, and click the Buffer Import button. If 
necessary, enter 1 for the Buffer Number (this is the default).

Also check the other tabs for correct values based on the earlier instructions 
(beam size 0.0052, decibel output, etc.)

3. Click OK.

Note:  When you import BPR data into CEF, you must use the default grid 
settings on the Computation tab of the Fiber Coupling Efficiency dialog box; 
this allows CEF to set the grid according to the imported BPR data in the buffer. 
You can change the output controls to Decibels, but don’t change the FFT Grid 
Size or other parameters at the top of the Computation tab.
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The following output shows that the coupling efficiency is a little better than the 
value predicted by the default CEF calculation, which is about -0.95 dB for the 
nominal value.
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A Grating-Based WDM 
System

This chapter will describe the steps needed to set up a grating-based WDM demul-
tiplexor, a device that takes a multi-wavelength input and feeds wavelength bands 
into output fibers. This system is closely related to grating spectrometers and 
monochromators used in various analysis instruments.
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Background on This Example
The grating demultiplexor system shown below is part of a WDM system that takes 
a multiple wavelength input beam from a fiber and uses a diffraction grating to split 
the wavelengths into separate output beams (the picture below uses two separate 
View Lens windows and represents the final design, including the multi-
wavelength zoom optimization discussed at the end of this chapter).

This system is very similar to grating-based spectrometers and monochromators 
that have been used for many years in scientific instruments. The application of this 
particular “Littrow grating configuration” to fiber optics has been described in the 
literature since at least 19771. The numerical values are based on the assumption of 
a 20 mm focal length lens combined with typical optical fiber and diffraction 
grating parameters.

We will assume that the output beams are collected by separate fibers and will use 
the coupling efficiency into these fibers to measure the quality of the system. Note 
that while this model is similar to configurations used in some real WDM systems, 
properties such as the channel spacing between output fibers are not necessarily 
realistic. To keep the example relatively simple, no particular channel spacing was 
assumed. It works out to about 24 microns. In a real de-multiplexor, this spacing 
would be closer to 128 microns. The point of this example is not to design a 

1. For example: Tomlinson, W.J., Applied Optics, Vol. 16, No. 8, August, 1977.
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working system, but to show you the steps and techniques needed to model any 
similar system. Values for basic input specifications such as wavelengths and beam 
divergence (fiber NA) are realistic.

The Game Plan
This chapter has a lot of steps, but the problem we are trying to solve is not as 
complex as the number of steps might suggest. First of all, the basic configuration 
is one that is known to work for this problem, and we are assuming that the grating 
properties have been predefined. We will also assume that the goal is to use a single 
lens element to collimate and re-image the light, even if this means using an 
aspheric lens (multi-element solutions are also possible of course). The game plan 
for the rest of the chapter is this:

1. Describe how light from a single mode fiber is modeled in CODE V.

2. Use the New Lens Wizard to open a single lens (singlet) from the CODE V 
samples.

3. Scale and modify the lens for the desired use.

4. Duplicate the lens surfaces to allow a double-pass configuration, insert a mirror 
to fold the light path into the second copy of the lens, and use pickups to link 
together separate CODE V parameters that correspond to single physical 
parameters. This keeps the model physically realistic whenever such linked 
parameters changed.

5. Change the mirror into a diffraction grating and tilt it so the light again passes 
through the lens on the second pass.

6. Optimize to get the correct tilt angle, and then to improve the image quality on 
the image surface (output fiber) for a single wavelength.

7. Analyze the coupling efficiency at the design wavelength, then at multiple 
wavelengths (telecom C band).

8. Set up a zoom system to optimize multiple wavelengths simultaneously, for a 
more realistic physical configuration (i.e., make sure input and output beams do 
not conflict).

That’s the plan. Now let’s get started.
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Modeling Fiber Input
CODE V does not explicitly model the optical fibers that provide input to this 
system, but instead requires that you specify the properties of a point source of light 
on the end of the fiber that is equivalent to the actual fiber's light output. These 
object properties include wavelengths, divergence (numerical aperture), beam 
location, and intensity profile. You could also specify polarization properties, but 
will not in this case. 

More detailed properties and additional components can always be added later if 
you want to refine the design or analysis. For example, you will start with one 
wavelength, but later will define a range of wavelengths to evaluate the WDM 
performance of the system.

For a typical system using infrared lasers and Corning SMF-28 single-mode fiber, 
the basic properties are as follows:

We will discuss the relationship between these specifications and the required 
CODE V input data. Some of these values will be entered in the New Lens Wizard 
during the initial definition of the lens, while others will be entered in the System 
Data window (discussed later).

Wavelength
The wavelength used in this example is 1550 nm, which is an infrared wavelength 
at the center of the telecom C wavelength band (about 1534 to 1566 nm). Although 
this WDM system is meant to work with multiple wavelengths, you can optimize 
and analyze it monochromatically first, then analyze its multi-wavelength 
performance using various techniques, including a special macro for plotting 
coupling efficiency vs. wavelength. 

CODE V supports up to 21 simultaneous wavelengths. Many optical systems are 
polychromatic, using multiple wavelengths at the same time (e.g., camera lenses). 
With such systems, most CODE V calculations are polychromatic, considering all 

Property CODE V Equivalent Typical Value

Wavelength in nanometers Wavelength (WL) 1550 nm 

Beam divergence Numerical aperture (NAO) 0.144

Intensity profile Gaussian apodization (PUI) 0.135 at 0.66 pupil fraction

Input fiber lateral offset Object height (YOB) 0.15 mm
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wavelengths simultaneously, with the contribution of each wavelength determined 
by a wavelength weight. Optimization also considers all wavelengths 
simultaneously.

Telecom systems and many non-telecom grating-based systems, such as 
spectrometers, are multiple wavelength systems, but are not polychromatic. This 
means that the system must be designed to handle a specified range of wavelengths 
(e.g. the telecom C band), but each wavelength is handled separately for analysis 
purposes. In practice, some of the wavelength weights must be set to zero to turn 
off all wavelengths except the one desired for analysis. CODE V’s zoom feature is 
a convenient way to do this that also allows “separate but simultaneous” 
optimization. This method will be introduced at the end of this chapter.

Numerical Aperture and Intensity Profile
Next we’ll discuss the divergence or numerical aperture as well as the intensity 
profile (assumed Gaussian) of the input beam. These parameters can be derived 
from the mode radius of the fiber, which is a standard data sheet specification for 
single-mode fibers. For SMF-28, the mode radius for 1550 nm is 0.0052 mm (5.2 
microns). You normally define the divergence of the beam in terms of the 1/e2 
intensity radius.   The 1/e2 far-field beam angle of a Gaussian beam of wavelength 
λ and mode radius wo is

θ =  λ / (π wo)

You can substitute the wavelength 1.55 μm (1550 nm) and mode radius 5.2 μm and 
calculate a value of 0.09488 for the 1/e2 angle. However, you can avoid 
substantially truncating the beam by extending the numerical aperture out beyond 
the 1/e2 point—for instance, to the 1% point instead. In this case the 1/e2 point is 
only 0.66 of the numerical aperture, which is 0.144. (0.09488/0.66 = 0.144). 

As described above, you want the intensity to drop to 0.135 (1/e2) at 66% of the 
radius of the entrance pupil. Later you will choose the Lens > System Data menu, 
go to the Pupil Apodization page in the System Data window, and enter 0.135 for 
Intensity and 0.66 for both X and Y components of Relative Aperture Coordinates 
(these can be different in some systems, e.g., some laser diodes have anamorphic 
output). Since the 1/e2 point is at 66% of the pupil radius, there should be little 
beam clipping if you size the optics to match the NAO value, which is essentially 
how CODE V calculates default apertures. If you are modeling a system with 
known surface apertures, you should enter those on the appropriate surfaces. In this 
case, analysis options will honor the specified aperture sizes, even if these do not 
match the specified object (input fiber) numerical aperture.
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Object or Field Definition
In this double-pass system, the light will pass through the lens, reflect from the 
grating, and pass again through the lens before being focused on the output fibers or 
detectors. The input fiber will need to be laterally offset to allow space for the 
output fibers. In CODE V, this lateral offset is defined by the object height, which is 
one of several ways to define the field of view of the system. 

Although optimization will offset the image for the single design wavelength 
(1550 nm), you will also need to check the other wavelengths in this dispersive 
system to be sure that none of their output beams overlaps the input beam. This will 
actually turn out to be a problem, and it will be addressed at the end of this chapter, 
when zoom will be used to model three wavelengths.
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The New Lens Wizard
You will be using an aspheric single lens in this example, setting it up as double 
pass. This means that the light from the input fiber will pass through the lens, 
reflect from the grating, pass a second time through the lens, and be collected in one 
or more fibers laterally displaced from the input fiber. This will require a few steps, 
but to begin, you need a single lens, and you can use the New Lens Wizard to get 
one.

Getting Started
1. Start CODE V.

2. Choose the File > New menu to launch the New Lens Wizard.

If the New Lens Wizard does not launch, choose the Tools > Preferences menu, 
and be sure the Use Wizards checkbox is checked on the UI tab.

3. Click Next to dismiss the Welcome screen.

4. Click the CODE V Sample Lens button (default) on the next screen. Click 
Next.

5. Scroll the list of sample lenses to find the file cv_lens:singlet.len, click on that 
file name, then click Next.
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6. On the Pupil screen, accept the default settings for now, and click Next.

Later you will change the pupil definition to Numerical Aperture - Object 
(NAO).

7. On the Wavelengths screen, double-click the single wavelength value of 
500 nm and change it to 1550 nm. Click Next.

8. Click Next on the Reference Wavelength screen to accept the default value.
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9. On the Fields screen, change the type to Object Height, and change the Y 
Height of the single field point to 0.15, then click Next.

10. Click the Done button on the New Lens Wizard’s Congratulations screen to 
complete the initial setup.

The following figure shows how the LDM spreadsheet will look. More changes 
will be needed to use this lens for the demux example.

Making a Lens Picture
As you set up the system, it’s a good idea to use a lens picture to be sure things are 
as you expect. It's often easier to catch errors by looking at a picture. You can then 
use Edit > Undo (perhaps multiple times) to reverse any unintended actions.

The View Lens feature is very flexible, and as you add surfaces and other 
properties, you will need to change its settings (e.g., surface range). But for now, 
you can use the default settings.



38 CODE V Photonics Modeling Guide

Chapter 3 A Grating-Based WDM System

1. Choose the Display > View Lens menu.

The View Lens dialog box has a number of tabs and input controls.
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2. Click the OK button.

The lens picture is shown below.

As you modify the lens through this chapter, you can update this picture at any 
time by clicking the Execute (re-calculate) button on the top left.   When surface 
numbers or other features change, you will need to use the Modify Settings 
button to open the dialog box to change the input settings (currently default 
settings).

Solves, Scaling, and System Data
There are two solves in this lens: one for curvature, and one for paraxial image 
distance. Solves are used to set system data to values required to achieve certain 
specified properties, usually in terms of first order or paraxial ray trace data. Since 
you will be scaling and otherwise modifying this lens from its original purpose, 
solves may cause changes you don't want, so you should delete them now.
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1. In the LDM spreadsheet window, right-click on the Y Radius of surface 2, and 
choose Delete Solve from the shortcut menu as shown below.

2. Right-click on the Thickness of surface 2, and choose Delete Solve.

This lens currently has an effective focal length (EFL) of 100 mm. How can you 
tell this? You can place EFL on the status bar at the bottom of the screen (choose 
the Tools > Customize menu and click on the Status Bar tab). You can also 
find the EFL from the Display > List Lens Data > First Order Data menu. For 
compact size, you will scale the lens to a focal length of 20 mm.

3. In the LDM spreadsheet, select surfaces (rows) 1 to 3.

Note that surface 1 is actually labeled as “Stop,” indicating the aperture stop 
surface, which is surface 1 by default. The aperture stop is the surface whose 
aperture limits the light-gathering ability of the system. We will eventually 
make the diffraction grating the stop for this system. 

4. Right-click on any selected row and choose Scale from the shortcut menu.
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The Scale dialog displays. Note that the surface range matches the selected sur-
faces.

5. In the Scale dialog box, click the Scale Effective Focal Length button, enter 20 
in the Scale Value field, and click OK.

You want the output of this lens to be approximately collimated (rays parallel to 
the Z axis), so the object (fiber) should be about 20 mm from the lens (i.e., at the 
focal length distance, using the lens “backwards” to spread out a focused point 
into a parallel beam). 

6. Click in the thickness cell for the object surface (the value is currently Infinity) 
and enter 20, then click or tab to another cell to enter the new value.
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Re-Drawing the Lens
You should re-draw the lens in the View Lens output window to see the effects of 
these changes. If you just click the Execute button, you will see something like this:

What’s wrong? The lens is very small and the image surface (vertical line) is very 
big. VIEW uses the paraxial image height size for drawing the image surface. With 
the object distance set to 20 (object near the focal point), the paraxial image 
distance is long, and the paraxial image height very large (choose the Display > 
List Lens Data > First Order Data menu to see the numbers). The solution is to 
change the surface span for the drawing.

1. Click the Modify Settings button in the View Lens window.

The View Lens dialog box is displayed.

2. On the Plot Parameters tab, change the Surface span Start Surface value to 
Object, and the End Surface value to 2, then click OK.

The picture looks better now, although only the chief ray is traced. Keep this 
window open so you can re-run or update it for later changes (it will remember 
the settings you have entered as long as you keep it open). 
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Completing the System Data
Now that the lens has a finite object distance, you can redefine the pupil size in 
terms of numerical aperture, based on the characteristics of the input fiber 
discussed earlier.

1. Choose the Lens > System Data menu. In the System Data window, click 
Pupil in the navigation tree to go to the Pupil page.

2. Change the Pupil Specification field from Entrance Pupil Diameter to 
Object Numerical Aperture.

3. Enter 0.144 in the Value field.

You can also define the pupil intensity in the System Data window, on the Pupil 
Apodization page. As discussed earlier, the intensity of a single mode fiber is 
well-approximated by a Gaussian.
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4. Click Pupil Apodization in the System Data window’s navigation tree (found 
under Advanced) to open this page.

5. For Gaussian Pupil Intensity (Intensity field), enter 0.135.

6. Enter 0.66 for both Relative X and Y Coordinates, then click or tab to another 
field.

Finally, you can define a new title for this system.

7. Click System Settings in the navigation tree to open this page.

8. Enter a new title such as Demux in the Title field and click or tab to another cell 
to commit this data.
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9. You can make a new picture by clicking the Execute button on the View Lens 
window.

The new output looks like this.
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Double-Pass Setup
Physically, all you need now is to define the reflecting grating to complete the 
system, but in the sequential ray tracing model normally used by CODE V, it’s 
necessary to define elements a second time if the light passes through them a 
second time (this is called a double-pass system). There is an alternate method 
called non-sequential surface modeling that doesn’t require this, but such NSS 
systems have other complexities and are not needed in this case.

Importing Surfaces
Although you could insert surfaces and use copy and paste to define the second 
instance of the lens, there is an easier way. The import surfaces feature (CODE V 
command COP) is meant for duplicating ranges of surfaces from the current lens or 
from another saved lens file. It has several special settings for ordering the copied 
surfaces, based on the intended use. You can flip surfaces (reverse the order of the 
copied and inserted surfaces) for use in symmetric or double pass applications. You 
can also scale the properties by -1 to account for reflection, but in this example you 
will do that in a separate scaling step.

The Import Surfaces dialog box has a file name field that is used to select a 
saved.LEN file if you need to copy surfaces from another lens, but in this case, you 
are duplicating surfaces from the current lens. You can either leave the file name 
blank, or enter an asterisk (*). 

1. Click on the image surface in the LDM spreadsheet to set the insertion point 
(new surfaces will be inserted in front of the selected surface).

2. Choose the Edit > Import Surfaces menu.

The Import Surfaces dialog box is displayed.
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3. Leave the lens file name blank, change the surface range (From 1 to 2), and 
click the Flip About Y Axis button. Click OK.

4. In the View Lens window, click the Modify Settings button, set the End 
Surface value to Image, then click OK.

The following lens picture is generated.

Inserting the Mirror
The lens element has been duplicated, as shown in the “unfolded” picture above, 
and will soon be aligned with its earlier representation. But first you need an 
additional surface to model the grating between the two copies of the lens. For now, 
we will approximate the grating surface with a mirror.

1. In the LDM spreadsheet, click on the surface number of surface 3 to select it, 
then right click and choose Insert from the shortcut menu.

2. In the Insert Surface dialog box, enter 1 for the number of surfaces to be 
inserted and click OK.

3. In the LDM spreadsheet, double-click the refract mode for surface 3 and choose 
Reflect from the shortcut menu.

4. Click the thickness cell for surface 2, choose the Edit > Copy menu, then use 
the Edit > Paste menu to duplicate this value for the thickness of surface 3.
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5. Select surfaces 3 to the Image, right-click and choose Scale. In the Scale dialog 
box, be sure that Scale by Factor is selected and enter -1 (negative one) for the 
Scale Factor.

The LDM surface data should look like the following:

6. Update your settings for the View Lens window by again clicking the Modify 
Settings button and changing the surface numbers on the Plot Parameters tab 
to start at Object and end at Image, since another surface has been inserted. 
Click OK in the View Lens dialog box.

The following lens picture is generated.
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Notice that the two copies of the lens now overlay perfectly, so it appears to be 
only one lens element (which of course it physically is). The rays pass through 
the lens twice but do not overlay exactly due to the object offset and aberrations.

Using Pickups
Although the second pass surfaces are now properly defined and positioned, they 
will not stay that way if you vary them during optimization. AUTO would treat 
each variable as independent, and you could end up with a physically impossible 
solution in which a radius of curvature of the lens changes value after the reflection. 
To prevent this, you must couple the corresponding parameters together, or better 
yet, use pickups to keep the corresponding values identical through any change to 
the lens.

Pickups establish a relationship between two lens parameters of the same or even 
different type, with optional scaling and offset parameters. A very common scaling 
parameter is -1 which is used to duplicate a value with the opposite sign, a frequent 
need in double pass, reflecting systems.
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Defining Pickups
The procedure is done in the LDM spreadsheet window and is the same for any type 
of parameter. 

1. Right-click on the cell for the item and surface number whose value you wish to 
“pick up” from an earlier value, and choose Pickup from the shortcut menu.

Note that the item you are picking up from (source value) need not be of the 
same type as the item you are defining, though it usually is, and this is the 
default.

2. In the Pickup Editor dialog box, choose the surface number whose value you 
are picking up.



CODE V Photonics Modeling Guide 51

Chapter 3 A Grating-Based WDM System

You can also choose the Parameter type if it is different from the value you are 
defining (the default parameter is “same as dependent parameter,” but this was 
explicitly changed to Thickness in the example above). If there is a reflection 
between the source and picked-up surfaces, you may need to scale the range of 
surfaces after the reflection by entering -1 as shown.

The table below summarizes the needed pickups. Note that they are all of the 
same type in this example (i.e., thickness picked up from thickness). Note that 
the pickup of thickness 5 from the object thickness deliberately changes the 
value (from -19.3 to -20).

Here is the LDM spreadsheet window showing all the pickups.

Since pickups will actually change lens data, a simple mistake such as an incor-
rect sign could change the lens form. It's best to check the numbers carefully 
and to make another lens picture.

Right-click... Surface Pickup from Scale

Surface type (profile) 4 2

Surface type (profile) 5 1 (stop)

Thickness 3 2 -1

Thickness 4 1 (stop) -1

Thickness 5 Object -1

Glass 4 1 (stop)
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3. In the View Lens window, click the Execute button to re-draw the lens.

The picture should not change from the previous step.

You have done quite a bit of work on this lens already, so it might be good to 
save the lens file if you have not already done so.

4. Choose the File > Save Lens As menu.

5. In the Save As dialog box, enter a name for the lens file, such as 
DemuxStart.len, and click the Save button.

You can change to a different directory before saving, as with any Windows 
application.
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Modeling the Grating
The reflecting surface is in place, but you need to add grating parameters. 
Diffraction will change the ray angles from that of a simple reflector, so the grating 
will also need to be tilted to the correct angle to get the rays to pass through the lens 
on the way back. You can use trial and error to get the approximate tilt angle, then 
use optimization to refine it.

Creating the Grating
You are almost done defining the optical system, but you are missing some details, 
especially for the grating. The grating is what separates the wavelengths in the 
device, and its surface properties and tilt angle must be set to allow this. First you 
need to make the grating the size-limiting or “aperture stop” surface of the system. 

1. In the LDM spreadsheet, right-click on the surface number for surface 3 and 
choose Set Stop Surface to make the mirror the aperture stop surface.

2. Right-click on the surface type for surface 3 and choose Surface Properties.

This will open the Surface Properties window.

3. Click Diffractive Properties in the Surface Properties window’s navigation 
tree to go to that page.

4. Choose Linear Grating in the Type field.
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5. In the spreadsheet on the Diffractive Properties page, enter -1 for the Grating 
Order and 0.001 for the Grating Spacing.

Gratings diffract light into multiple directions called orders, although they are 
usually designed to put most of the energy into one particular order, which we 
will assume to be -1 in this case. The Grating Spacing (in lens units, 0.001 mm; 
in this case, 1 micron) determines how dispersive the grating is—smaller values 
will diffract the light over larger angles, as a function of wavelength. This value 
represents a grating with 1/.001, or 1000 lines/mm. The Grating Direction val-
ues default to (X=0, Y=1, Z=0) which is correct for this case (rays will be dif-
fracted in the +Y direction).

Note:  CODE V estimates the scalar diffraction efficiency, or the amount of energy 
going into a given diffractive order, for a number of blazed grating profiles: kinoform, 
step approximation to a kinoform, or sinusoid. The grating profile determines only 
the diffraction efficiency of the rays; the direction and optical path lengths of the rays 
are determined by the grating order and spacing. For details about CODE V’s scalar 
diffraction efficiency calculation, see page 4-116 in the CODE V Reference Manual.



CODE V Photonics Modeling Guide 55

Chapter 3 A Grating-Based WDM System

Tilting the Grating
Now you must tilt the grating so the diffracted rays will re-enter the lens. You can 
use trial and error, changing the angle and updating a lens picture window to find 
the approximate value, which will be about -45° (this angle will be in the YZ plane, 
which is an alpha tilt, or ADE in CODE V terminology). 

You can then use constraint-only optimization to find the value that places the 
output beam where you want it (at about -0.30 mm below the Z axis).

1. Click Decenters in the Surface Properties window’s navigation tree (make sure 
you are working on surface 3, now called Stop).

The Decenters page is found under Advanced in the Surface Properties naviga-
tion tree. If you have closed the Surface Properties window, right-click on sur-
face 3 and open it again.

2. Use the dropdown list to change the Decenter Type from None to Decenter 
and Return.

The decenter and return establishes a “temporary tilt” for the current surface 
only, re-aligning the exiting coordinate system with the entering coordinate sys-
tem for the surface, which will keep the double pass configuration intact (i.e., 
the second copy of the lens element will still be aligned with the first, as you 
can tell from a lens drawing).

3. Enter -45 in the Alpha field and press the Tab key.

4. Right-click on the Alpha value and choose Vary from the shortcut menu.

You will soon use AUTO to optimize this value for the correct output ray path. 
Right now the ray path is looking a bit ragged (re-run the still open View Lens 
window).
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You can now use optimization to adjust the tilt angle to get the proper ray path, 
using a single variable. You will then set up additional variables and do addi-
tional optimization to improve the performance.

Optimizing the System
Although you could try running some analysis options now, it’s clear from the lens 
picture that this system is grossly aberrated. You will use three steps to optimize 
this system:

1. Run AUTO in constraints-only mode to vary the grating alpha tilt angle to 
satisfy a single specific constraint: the chief ray height on the image surface.

2. Define aspheric and other variables to use for improving the image quality.

Note:  You can also estimate a starting angle from the grating equation:

sin I - sin I' = mλ/d

where I is the incident angle, I' is the diffracted angle, m is the grating order (-1), λ 
the wavelength (1.55 μm), and d the grating spacing (1μm). If you assume I = I' (not 
quite true, but close) and solve 2 sin I = mλ/d for I, you get -50.8°. This is very close 
to the optimized result. Not all problems have such a simple equation to solve, so 
trial-and-error followed by the constraint-only optimization approach is a very 
useful technique.
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3. Run AUTO with a wavefront error function and additional constraints to 
improve the image quality.

Constraints Only for Tilt Solution
Although you could use trial and error to refine the value of the grating alpha tilt, 
AUTO provides a convenient way to solve such problems. Note that it does 
generally require a starting point that at least traces the reference rays. If this is not 
the case, AUTO tries reducing the field and pupil size temporarily, but this often 
does not work. For this case, the estimated value of -45° is close enough to 
optimize. First you need to freeze any variables other than the tilt angle.

1. In the LDM spreadsheet, click and drag to select the Y radius cells for surfaces 
1 and 2, then right click and choose Freeze from the shortcut menu.

Note that the V (variable) symbol disappears from these cells when you do this.

2. Right-click on the image surface thickness and choose Freeze.

3. Choose the Review > Variables and Couplings menu to display the Variables 
and Couplings spreadsheet. Make sure that the only parameter listed is the 
Alpha tilt of the Stop (grating) surface.

4. Choose the Optimization > Automatic Design menu.

The Automatic Design dialog box is displayed.

5. On the Error Function Definition and Controls tab, choose Constraints 
Only Solution from the Error Function Content dropdown list.
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6. On the Specific Constraints tab, click the Insert Specific Constraint button.

The Edit Constraint dialog box is displayed.

7. In the Edit Constraint dialog box, choose Real Ray Trace Data in the Category 
field, choose Local Y Surface Coordinate in the Constraint field, and click in 
any non-gray field.

This allows the program to update the available data fields for the chosen con-
straint (different constraint types require different combinations of parameters). 
In this case, the defaults are right except for the target (Image surface, field F1, 
chief ray, wavelength W1, constraint mode equality). Click the Calculate 
Default Target button to see the current value of this target, which is the real-
ray image height.

8. Enter -0.30 as the Constraint Target and click Apply & Close.

9. Click the Output Controls tab, then click the Draw system at each cycle 
checkbox.
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10. Click OK to run this optimization. 

The Automatic Design tabbed output window is generated.

The solution is just what was requested—solving only the single real-ray con-
straint, but still with very poor image quality. If you scroll down to the end of 
the Text tab you will find that the final alpha tilt value is about -50.6° (ADE 
S3). Keep this tabbed output window for AUTO (you can resize, move or 
minimize it). You will next add aspherics and variables in the LDM and modify 
the AUTO inputs for image quality optimization.

Aspherics and Variables
Optimization requires appropriate variables and an error function to represent the 
system quality. Variables are designated by you by right-clicking and choosing 
Vary from the shortcut menu, as you have seen in previous procedures. You can 
start out with CODE V’s default error function for wavefront error, but you will 
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impose a constraint on the airspace length to prevent the system from getting too 
long (this is usually determined by trial and error). You will also constrain a ray on 
the output (image surface) to lie at least 0.3 mm below the input fiber (for 
mechanical spacing). To get additional degrees of freedom to correct aberrations, 
you will make both surfaces of the lens aspheric and vary the aspheric coefficients 
to get the best performance. The profile pickups that you entered earlier will 
automatically make the pickup surfaces identical aspheres as well. Aspherics are 
more expensive to manufacture than spherical lenses, but there are now various 
production methods that can make aspheres a cost effective alternative to multiple 
spherical elements for many systems.

1. In the LDM spreadsheet, right-click on the surface type for surface 1 and choose 
Surface Properties from the shortcut menu.

2. On the Surface Type page of the Surface Properties window, change the Type to 
Asphere (choose from dropdown list), then click another field.

3. Right-click in the value cells for the 4th and 6th order coefficients (A and B) and 
choose Vary Parameter for both.

4. Change the surface selector (upper left) to surface 2, and make surface 2 an 
Asphere with 4th and 6th order coefficients (A and B) variable.

5. Back in the LDM spreadsheet, right-click and choose Vary for the Y radius 
values for surface 1 and surface 2.

6. Right-click and Vary the thickness for the object surface and surface 2.

7. Right-click and Vary the glass of surface 1.

Note that the glass BK7 will be changed into a fictitious glass designated 
516800.641673 (index of 1.5168, V-value of 64.1673). Fictitious glass is a 
model that allows the glass properties to vary for optimization (catalog glasses 
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such as BK7 have fixed properties and thus cannot be variables). Optimized fic-
titious glasses must be converted to real glasses for final analysis and manufac-
ture (the supplied macro glassfit.seq can help you with this task).

8. Choose the Review > Variables & Couplings menu, and verify the 10 
variables shown below in the Variables and Couplings spreadsheet.

The Coupling Code value of zero indicates a variable, which will also be indi-
cated by the V symbol in the LDM spreadsheet or Surface Properties window.

9. Choose the File > Save Lens menu to update the saved copy of this lens data. 

Optimizing the Lens
Now that you have defined aspherics and other variables, you should have enough 
degrees of freedom to improve the image quality with AUTO.

Note:  Varying glass is not really necessary for a monochromatic system, but it 
is included here to show the techniques. The fictitious glass model is really 
intended for visual wavelengths, so any fictitious glass should eventually be 
replaced by a real glass, followed by a final optimization to be sure its 
performance in the infrared is as expected.
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1. Click the Modify Settings button in the Automatic Design window used 
previously.

The settings made earlier will still be in place, but you will need to change some 
of them and add some others.

2. On the Error Function Definitions And Controls tab, change the Error 
Function Content to CODE V Error Function Only. 

3. Change the Ray Interval to 0.22 (under Ray Grid Controls).

Note that this step is not required, since CODE V sets the ray interval to 0.22 
whenever non-spherical surfaces are in the lens. However, it’s good to be aware 
that you can change this ray spacing, since it can greatly affect the solution.

4. On the Specific Constraints tab, change the Mode for the previously entered Y 
ray constraint to < Upper Bound.

It’s acceptable if the output beam is displaced below -0.30 mm.

5. Click the Insert Specific Constraint button to display the Edit Constraint 
dialog box.
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6. In the Edit Constraint dialog box, choose the following:

– Category: Manufacturing and Packaging

– Constraint: Center Thickness

– Start Surface: 2

– Constraint Mode: > Lower Bound

– Constraint Target: 10

Click Apply.

7. With the Edit Constraint dialog box still open, repeat the above step exactly, 
with the following exceptions: make the mode < Upper Bound and the target 
25. Click Apply & Close.

The combined effect is to hold the air space between the lens and the mirror to 
between 10 and 25 mm. It is often necessary to enter the same constraint twice 
to establish lower and upper bounds. The command language allows a shortcut 
for this (CT S2 > 10 < 25), but this is still entered as two separate constraints.
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8. Check the Specific Constraints tab to be sure your constraints match the ones 
below.

9. Click OK to run the optimization.

Your final screen should look something like this (rays start just before surface 
1, not at the object surface). Note that the beam is well focused and the final 
error function is a small number (zero is considered perfect for optimization 
purposes, but the true performance must be determined by analysis).

10. Choose the File > Save Lens As menu and give the optimized lens a new name 
(for example, DemuxOpt.len).
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Analyzing the Performance
This system is intended for multiple wavelength use (WDM) over the telecom C 
band, but to start with, you should analyze the coupling efficiency at the design 
wavelength, 1550 nm. You can then use a macro to analyze the coupling efficiency 
over multiple single wavelengths. Other analysis or optimization will require 
special techniques, including zooming the wavelength weights and reference 
wavelength. This is because the system is not polychromatic, but instead is a 
multiple wavelength system, where each wavelength must be analyzed and 
optimized with reference to its own chief ray.

Coupling Efficiency
Coupling efficiency (CEF) was discussed in detail in Chapter 2, where it was used 
to analyze a simple ball lens coupler. The same inputs will apply here, so we will 
present only the steps, and show the fiber location setting in the System Data 
window that is used differently from the ball lens examples. Only non-default 
settings are noted.

1. In the System Data window (Lens menu), on the Fiber Location page, double-
click the cell for Location, and choose Compensated.

2. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu.

The Fiber Coupling Efficiency dialog box is displayed.

3. On the Fiber Specs tab, choose Gaussian mode, and enter 0.0052 for the 
radius.

Recall that the Gaussian mode profile is a good approximation to SMF-28 fiber, 
with a mode radius of 0.0052 mm (5.2 um) at 1550 nm. 
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4. On the Computation tab, enter 0.001 as the Focal Plane Increment, and select 
the Decibel Scale checkbox (Output Controls area). The 0.001 increment 
ensures that at least 10 samples across the mode diameter and is a good default 
for fiber coupling systems. Often it is not necessary to select a focal plane 
increment, but if you want to ensure adequate sampling you can explicitly set 
this parameter.

5. On the Sensitivity Analysis tab, keep the defaults of X and Y displacement 
(output fiber decentering), but change the maximum values to 0.005 and the 
Number to 5.

This defines the calculation, but you also need to specify the location of the 
fiber. The default is to fix the fiber on the axis (at X=0, Y=0 on the image sur-
face). For centered systems, this is a good choice (and you may also choose to 
move or tilt the fiber from this position). But in this case, with a tilted system, 
you can choose the second option and have CEF “compensate” for the position 
of the fiber with respect to the chief ray.

6. Click OK.

The output shows that the nominal (centered on chief ray) coupling efficiency is 
good, with an insertion loss of about -0.08 dB. It drops off rapidly with decen-
tering as you might expect. The plot shows this quite clearly.
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Coupling Efficiency vs. Wavelength
CEF itself only calculates the coupling efficiency for the reference (primary) 
wavelength of the optical system, but for WDM applications, coupling efficiency 
vs. wavelength is obviously important. ORA has written a macro for the common 
case of evaluating CEF over a series of wavelengths. This macro is called 
CEF_VS_WL.seq, and is available as a sample macro in the Macro dialog box. 
CEF_VS_WL has a GUI input dialog box, making it very easy to use.

1. Choose the Tools > Macro Manager menu.

2. In the Sample Macros list, click Photonics Analysis.

3. Click cef_vs_wl.seq.
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4. Click Run to run the selected macro.

5. Enter the parameters in the macro input dialog box as shown below. For the 
CEF command string (only partially shown below), enter:

CEF;MPR GAU .0052;DB -30;TGR 128;GRI .001;GO

6. Click OK.

The following output is generated.
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You can see that even though you have optimized the system at only a single 
wavelength, that the coupling efficiency is better than –2 dB from 1500 to 1600 
nm. In fact, over the C-band range of 1534.25 to 1566.31 nm, the worst inser-
tion loss value is about -0.30 dB. This looks pretty good unless there are prob-
lems with getting to all of the output wavelengths.
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Zooming Wavelength Weights
What is not evident from the CEF_WL_PLOT macro output is the position of the 
output beam for various wavelengths.   You could investigate this by changing the 
single wavelength to various values and making a View plot or tracing single rays. 
If you do this, you will find bad news at the short end of the C-band spectrum 
(around 1534 nm). In optimizing to place the 1550 nm wavelength at -0.30 mm, the 
shorter wavelengths are displaced by a smaller distance, and they overlap the 
position of the input beam.

One thing you could do for this is simply optimize at the shortest wavelength in the 
desired band. This could work, since the longer wavelengths will all be displaced 
more than the shortest. But you may not get good performance across the whole 
band this way.

What Is Meant by Zoom?
The general solution is to optimize over multiple wavelengths, but while this is a 
simple matter for polychromatic systems, it's a little more complicated for multi-
wavelength grating systems such as this. It can be done by zooming the reference 
wavelengths and the wavelength weights. Zoom in CODE V really means multi-
configuration, although the method can be used for true zoom lens design. In this 
case, we only need to make a way for each wavelength to optimize to a separate 
point on the image surface. Polychromatic systems try to place all wavelengths at 
the same image point, and any deviation from this is chromatic aberration (a 
defect). In this case, placing each wavelength at a separate point is the goal of the 
system.

The basic idea of Zoom is to specify a number of positions (up to 99), then to zoom 
one or more parameters that can take on different values across zoom positions. 
Any parameter that is not zoomed uses the same value for all zoom positions, so 
input for zoom systems can be fairly brief, depending on the complexity of what is 
changing. If you want to learn more about zoom methods, please read Chapter 9 of 
the CODE V Introductory User’s Guide. 

A Slightly Shorthand Procedure
Since this chapter is already pretty long, we will adopt a slightly different format in 
this section, providing the step-by-step instructions, and briefly summarizing 
expected results, but using fewer screen shots and shorter explanations than in the 
rest of this guide. The good news is that very little change is required in the inputs 
for optimization and analysis to handle the zoomed system. Most of the work is in 
setting it up in the LDM.
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1. Choose the Lens > System Data menu, go to the Wavelengths page, then 
select the predefined Telecom C spectrum from the dropdown list and click the 
Use Spectrum button.

2. To zoom the reference wavelength, right-click the Reference Wavelength field, 
and choose Zoom from the shortcut menu. Click Yes in the dialog box that asks 
if you want to zoom the system.

3. In the Zoom System dialog box, change the description to 1566.31 Demux, 
change the number of zoom positions to 3 and press Enter. Edit the titles for z2 
(1550.12 Demux) and z3 (1534.25 Demux). Choose a plotting color for each 
zoom position, then close the Zoom System dialog box.



72 CODE V Photonics Modeling Guide

Chapter 3 A Grating-Based WDM System

4. Right-click again on the Reference Wavelength field, and choose Zoom. Since 
the system is zoomed, the Zoom Editor dialog box displays. Change the 
reference wavelength to W1 for Z1, W2 for Z2, and W3 for Z3 (as shown 
below). Then click OK.

5. To zoom the wavelength weights, right-click on the Weight for W1 and choose 
Zoom, and in the Zoom Editor dialog box, change the weights to 0 for Z2 and 
0 for Z3 (1 for Z1, default value). Click OK.

6. Right-click on the Weight for W2 and choose Zoom, and in the Zoom Editor 
dialog box change the weights to 0 for Z1 and 0 for Z3 (1 for Z2, default value). 
Click OK.

7. Right-click the Weight for W3 and choose Zoom from the shortcut menu. In the 
Zoom Editor, change weights to 0 for Z1 and 0 for Z2 (1 for Z3, default value). 
Click OK.
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8. Choose the Review > Zoom Data menu and use the Zoom Data spreadsheet to 
confirm that weight is non-zero only for the reference wavelength in each 
position.

9. Choose the Display > View Lens menu, and:

– In the View Lens dialog box on the Plot Parameters tab, make sure the 
surface span is object to image (zoom will not matter here since you will 
make a single overlay plot with all zooms).

– On the Title/Offsets tab, right-click the Return Pen to Origin checkbox 
and choose Zoom. In the Zoom Editor, check the boxes for Z1 and Z2 but 
leave Z3 blank (as shown) and click OK.
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– On the same tab, click Overlay zoom pos. at surface no. and choose Image 
as the overlay surface with no offsets (both return and overlay steps are 
shown above).

– On the Ray Properties tab, in the All rays spreadsheet, insert 2 lines, and 
make them Z1, Z2, and Z3 with colors red, forest green, and blue.

– Click OK, and note that the shortest wavelength (blue) image beam overlaps 
the object beam (picture with detail inset below produced with copy/paste in 
graphics program).
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10. Choose File > Save Lens As, and specify the file name demuxZoomStart.len 
or another name of your choice.

11. In the saved (still open) Automatic Design window used previously, click the 
Modify Settings button and do the following:

– On the Specific Constraints tab in the Automatic Design dialog box, 
modify the already defined Specific Constraint (Y < -0.3) to change to Z3 
and W3 (shortest wavelength - you must change both zoom and wavelength, 
and you may have to scroll horizontally to find the wavelength column)

– On the Error Function Definitions and Controls tab, change the Error 
Function Type to Fiber Coupling Efficiency, and the mode radius (all 
zooms, all wavelengths as shown) to 0.0052.

– Right-click the Ray Interval field, choose Zoom, and enter 0.05 for Z1; 
click the Replicate Z1 button, and click OK. Remember from Chapter 2 
(ball lens example) that a smaller ray interval is often necessary for 
optimizing on fiber coupling efficiency (0.05 is the default value for fiber 
coupling optimization, but since you changed this value earlier, you need to 
re-enter the default value in this step). This allows more rays to be entered 
into the optimization error function.
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– You may want to save these settings for later use by clicking the Option Set 
button, then the Save As button, and assigning a descriptive name to this set 
of inputs.

You don’t need this as long as you keep the AUTO window open in this session, 
but if you close the window or end the session, you can restore all the settings 
by clicking Option Set and then Load to view the list of saved settings.

12. Click OK in the Automatic Design dialog box to re-run optimization.

The system improves but the lens is thin. You can vary the thickness of the lens 
(THI S1) to allow CODE V to fix this.

13. Choose the Edit > Undo menu to get the starting lens back, right-click on the 
LDM thickness of S1 and choose Vary. Right-click on Asphere S1 and choose 
Surface Properties. Make the 8th-order coefficient variable; do the same for S2 
(right-click on the 8th-order coefficient and choose Vary).

14. Rerun AUTO by clicking the Execute button in the Automatic Design tabbed 
output window.

15. Click the Modify Settings button in the Fiber Coupling Efficiency tabbed 
output window. Go to the Computation tab in the CEF dialog box; then, right-
click the Focal Plane Increment field, choose Zoom, and set the Focal Plane 
Increment for Z1..3 to 0.001. Click OK.
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The coupling efficiency should be around -0.2 dB for Z1, -0.16 dB for Z2, 
-0.09 dB for Z3, which is not perfectly balanced (look at the Text tab of the out-
put window, scrolling to find output for each zoom position). Optimization 
WTF (field weights) for each zoom position may help by giving less emphasis 
to the “good” zoom positions.

16. Re-run VIEW (the former overlap of wavelengths is OK now; note that two 
separate View Lens windows are shown below).

17. Rerun AUTO, changing WTF values (X- and Y-Aberration Weights) to 1.0 for 
Z1, 0.5 for Z2, 0.4 for Z3 (trial and error to balance CEF across colors better).
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You may have to re-run the Automatic Design dialog box several times to get 
the best performance. AUTO stops when it sees little improvement, but re-run-
ning with the same settings five or six times will continue to improve the lens 
slightly. You can also change the settings on the Exit Controls tab to accept 
smaller improvement per cycle and to force more cycles (increase min and max 
cycles).

18. Re-run the CEF_VS_WL.seq macro (Tools > Macro Manager menu, or just 
click the Execute button if the output window is still open).

The coupling efficiency is within -0.2 dB in the 1534-1566 nm range. Further 
improvement may be possible, although convergence gets slow, and the disper-
sion properties of a single glass element will always produce chromatic aberra-
tion. Adding another glass element would likely be necessary to attain improved 
chromatic performance.

19. Choose the File > Save Lens As menu and save the optimized system under a 
new file name such as DemuxZoomOpt.len.
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Chapter 4

Coupling Efficiency 
Calculations 

This chapter shows you how to set up a fiber optic coupler using off-the-shelf 
aspheric lens elements made for this purpose by Geltech. It then shows you how to 
compare the results of several coupling efficiency calculation methods, including 
beam propagation.
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Methods of Calculating Coupling Efficiency
CODE V’s Coupling Efficiency option (CEF) can calculate the coupling efficiency 
in several different ways. In each case, an amplitude and phase distribution function 
is placed at the image point, and the coupling efficiency is calculated as the overlap 
integral between this function and the mode profile of the output fiber (which is 
also specified in CEF and is most often a Gaussian). The method is specified on the 
Beam Definition tab of the CEF option dialog box (Analysis > Diffraction > 
Fiber Coupling Efficiency menu).
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The four amplitude and phase distribution methods are as follows:

1. Ray trace the lens and determine the point spread function (PSF) at the image. 
This default method considers all aberrations in the system as well as the 
diffraction effects of apertures as mapped by ray tracing to the exit pupil of the 
system (the pupil function). This method can optionally include polarization 
effects, which may be important in some systems, especially when there are 
multilayer coatings.

2. Specify Gaussian beam parameters at the object surface. CEF then traces a 
Gaussian beam through the system to the image surface. The Gaussian beam 
trace is the same as that done by the BEA option (Analysis > Diagnostics > 
Gaussian Beam Trace menu), or by the supplied macro function 
GAUSSBEAM. These use a ray-based quasi-paraxial method to calculate beam 
parameters. This method considers Gaussian beam-spreading effects, but 
ignores all apertures as well as any aberrations other than astigmatism (see the 
BEA option section of the Reference Manual for technical notes on this 
calculation).

3. Specify the amplitude and phase directly as CODE V .int files, calculated 
somehow by the user (e.g., by a macro or external program of some sort). 
Again, CEF does not ray trace the lens itself if this method is used.

4. Calculate the amplitude and phase distribution by diffraction beam propagation 
(BPR option, Analysis > Diffraction > FFT Beam Propagation menu), and 
place the complex data in a worksheet buffer (a kind of data structure or file 
often used in macro programming). The CEF option can then import the beam 
propagation data at the image surface; this method can include the effects of 
diffraction at all internal surfaces and is the most accurate method for scalar 
calculations (BPR currently does not support polarization calculations).

We will show the ray trace, Gaussian beam, and beam propagation methods in this 
chapter, and see the effects of changing the air space in a nominally collimated 
space. But first you need to have a lens to work with.
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Defining an Aspheric Coupler System
There are various ways to construct fiber optic couplers, including the simple ball 
lens presented in an earlier chapter. When additional components such as filters 
must be included, you will typically want a design that includes a collimated air 
space between the elements. One common solution to this design is gradient index 
(GRIN) elements (the final chapter of this document briefly discusses such a 
design, provided as a sample lens). Another approach is to use conventional 
spherical-surface singlets, although aspheric singlets can give much better 
performance.

In this section, you will construct a two-element coupler based on a Geltech catalog 
lens designed specifically for this purpose (completed design shown below). The 
Geltech catalog is not yet provided with CODE V (we plan to supply it in a future 
release, adding it to catalogs from Melles Griot, Newport, Edmund Scientific, and 
several others available through the Edit > Insert Catalog Lens menu). You can 
request more information about the Geltech catalog from LightPath Technologies 
(www.lightpath.com). The information needed for this particular Geltech catalog 
lens is provided in this section.

It’s a useful exercise to set up a lens from scratch with data found in a Web or other 
catalog source. You can still use the New Lens Wizard for this purpose, using the 
steps in this section. As with the zoom section of the demux chapter, we will present 
the procedure in a slightly abbreviated form, without much explanation. If you did 
the earlier examples and follow the instructions carefully, you should have no 
trouble setting up this lens.

Note:  This lens model is also available as a macro (.seq) file on the ORA Customer 
Support Web site, http://www.oraservice.com. Click the CODE V Support link on 
the main page, click Macro and User-Defined Features Downloads, and click 
Photonics Macros. The macro is called asph_coupler.seq and it includes the 
analysis results discussed in this chapter.

http://www.oraservice.com
http://www.lightpath.com
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Lens Data 
Information about the Geltech catalog is available on the LightPath Technologies 
Web site (http://www.lightpath.com). This catalog contains detailed descriptions of 
a number of lens elements designed for coupling applications at various 
wavelengths and conditions (e.g., laser to fiber as well as fiber to fiber). From this 
catalog, we chose the lens element 350430, a 5 mm EFL molded plano-convex 
asphere designed for 1550 nm. The main properties of this lens are a numerical 
aperture of 0.15, working distance of 4.36 mm, outside diameter of 2.0 mm (CIR 
EDG in CODE V), optical clear aperture diameter of 1.52 mm (CIR in CODE V). 
The glass is C0550, a special optical glass for molding applications. The surface 
data (radius of curvature, conic constant, thickness) are provided with the lens data 
and are listed in the setup instructions below.

Creating a Blank Lens
1. Choose the File > New menu to start the New Lens Wizard, click Next on the 

Welcome screen, click the Blank Lens button on the “Where do you want to 
start from?” screen, and click Next.

2. On the Pupil screen of the New Lens Wizard, keep the pupil type as Entrance 
Pupil Diameter for now, make the value 1.52 (Geltech’s specified clear 
aperture diameter) and click Next.

3. On the Wavelengths screen, change the single wavelength to 1550, choose a 
color for plotting, and click Next. Then, click Next on the Reference 
Wavelength screen.

4. On the Fields screen, be sure the field type is Object Height, with X=0 and 
Y=0. Click Next, then click Done on the Congratulations screen.

5. In the LDM spreadsheet window, right-click the Image surface (click in the 
Surface # column) and choose Insert from the shortcut menu. In the Insert 
Surface dialog box, click OK to accept the default (inserting one surface).

http://www.lightpath.com/techspecs.html
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Defining the Glass and the Surfaces
The glass used for this aspheric lens element is called C0550, which is a glass with 
a relatively low melting point that works well in molding applications. The index of 
refraction as a function of wavelength is commonly defined by an equation called 
the Laurent Formula, and Geltech has supplied the coefficients for this material, 
shown in the table below, which can be used in CODE V to define a private catalog 
glass that is part of the lens data. 

C0550

A0 = 
2.5275

A1 = 
-8.24759e-3

A2 = 
1.61384e-2

A3 = 
7.10762e-4

A4 = 
-7.35332e-5

A5 = 
6.55454e-6
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To define the glass and surfaces:

1. Choose the Lens > Add Private Catalog Glass > Dispersion Formula menu, 
and in the Private Catalog dialog box, type the name C0550 (upper case C), 
accept the default type Laurent, and type the values for the six Laurent 
coefficients from the previous table. Check the values carefully (watch signs!), 
then click OK.

2. In the LDM spreadsheet, on surface 1 (stop surface), enter 2.928699 for radius, 
1.01 for thickness, and "C0550" for glass (you must type the glass name in 
quotes, either single or double). Right-click on Y Semi-Aperture and choose 
Change to Circular Aperture, then enter 0.76 for the value (this is 1.52/2).   
(If you prefer aperture diameters to semi-diameters you can select the aperture 
diameter preference with the Edit > Semi-Aperture Mode menu.)

Note:  Geltech also lists an outside diameter value of 2.0 mm, which corresponds 
to CODE V’s edge (EDG) aperture. You could define an edge aperture in 
addition to the optical clear aperture on each surface, but this would mainly 
affect the lens drawing. Edge apertures do not affect ray tracing results in 
sequential lens models.
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3. On surface 2, or the back surface of the lens, right-click on Y Semi-Aperture 
and choose Change to Circular Aperture, then enter 0.76 for the value. 

4. Right-click on the surface type (Sphere) for surface 1 and choose Surface 
Properties. On the Surface Type page in the Surface Properties window, 
change the type to Asphere and click any other field to commit this change. 
Change the Conic Constant (K) value to -0.58123316 and click any other field. 
You can then close the Surface Properties window (click the close box X in the 
upper right corner).

Back in the LDM spreadsheet, you need to determine the paraxial image dis-
tance and set the object distance to match this. The quickest way to do this is to 
define a paraxial image solve, delete the solve once the value is determined, 
then copy that value to the object thickness field.
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5. Right-click on thickness of surface 2 and choose Solve. In the Thickness Solve 
Editor, change the type to Paraxial Image Distance Solve and click OK. 
Right-click on the value (approximately 4.36) and choose Copy, then right-
click the same cell again and choose Delete Solve. Finally, right-click on the 
thickness of the object surface and choose Paste.

The LDM data should be as shown above, and if you choose the Display > 
View Lens menu, change the starting surface to Object, and click OK, you 
should get a picture like the following.

Setting Up Fiber Input and the Second Lens Element
Now that the lens has a finite object distance, you can define the numerical aperture 
on the object side (NAO) and input fiber intensity, just like the earlier examples in 
this guide. The lens element is facing the wrong way at the moment, but you will 
soon insert a flipped copy of it to complete the two-element coupler.

1. Choose the Lens > System Data menu, and on the Pupil page, change the 
Pupil Specification to Object Numerical Aperture and the Value to 0.15.

2. On the System Settings page, change the Title to Coupler from Geltech 
350430 Asphere.

3. On the Pupil Apodization page, enter 0.135 for Intensity, and enter 0.63 for X 
and Y (this is 0.09488/0.15 as explained in the demux chapter, for the same 
mode radius and wavelength and a slightly larger NAO).
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4. In the LDM spreadsheet, select the Stop surface row and choose the Edit > 
Import Surfaces menu. In the Import Surfaces dialog box, enter the surface 
range from 1 to 2, be sure that the Insert Before Surface is set to Stop, select 
the Flip About Y Axis button, then click OK.

The imported surface in this case is from the current lens file (the lens you are 
working with). This will insert a flipped copy of first element (s1..2) in front of 
the stop. The LDM spreadsheet will look like the following:
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5. Click the Execute (re-calculate) button in the View Lens window to see the 
completed lens.

6. Choose the File > Lens Save As menu and save this under a suitable name, 
such as asph_coupler.len
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Ray Trace Method: CEF Default Results
Now that you have set up the lens system, you can start with the ray trace method 
for calculating coupling efficiency. In the ray trace method, CEF ray traces the 
system to determine the diffraction PSF which it can then combine with the fiber 
mode data to calculate the coupling efficiency. This method was demonstrated in 
the earlier chapters in this guide that discuss the ball lens and demux system, so we 
will just review the steps here without screen pictures.

1. In the System Data window (Lens menu), on the Fiber Location page, use the 
default values. Be sure that the Location is Fixed at (0,0,0) for all fields, zooms, 
and wavelengths (this is the default).

2. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu. The 
Fiber Coupling Efficiency dialog box is displayed.

3. On the Fiber Specs tab, change the Gaussian mode radius to 0.0052.

4. On the Beam Definition tab, be sure that Ray trace lens system is selected 
(default).

5. On the Computation tab, select the Decibel Scale checkbox.

6. No inputs are needed on the Sensitivity Analysis tab.

7. Click OK to run CEF.

You can now change the thickness of surface 2 in the Lens Data Manager window 
and click the Execute/Recalculate button in the Fiber Coupling Efficiency window 
to update the CEF results. You will find that the insertion loss from CEF’s default 
calculation is very close to -0.049 dB no matter what value you set for the 
separation between the elements. 

But is this the right answer? For small separations between the elements, it is 
probably very close, but as the beam propagates over longer distances, it actually 
spreads out, while the rays in this calculation stay almost perfectly parallel 
(collimated). You can see this with the Gaussian Beam Trace option.
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Gaussian Beam Trace Method
Another method for calculating coupling efficiency is the Gaussian beam trace 
method. It is based on real ray tracing, but only the chief ray and a few nearby 
differential rays are traced in order to determine matrix elements for calculating 
Gaussian beam parameters at each surface. This “quasi-paraxial” procedure ignores 
all apertures and also ignores aberrations other than astigmatism. It does take into 
account beam sizes and wavefront radii of curvature, both of which can be different 
in x and y. The Gaussian Beam Trace option (BEA) traces and displays the beam 
data, while the Coupling Efficiency option (CEF) performs the same calculation, 
but only uses the image surface value.

Running Gaussian Beam Trace (BEA)
The Gaussian Beam Trace option can give you useful diagnostic information about 
beams in photonics systems. It can also help you visualize the Gaussian beams with 
shaded depictions of the beams superimposed on a lens picture.

1. In the LDM spreadsheet, make sure the lens has its original thickness value for 
surface 2 (4.3632 mm).

2. Choose the Analysis > Diagnostics > Gaussian Beam Trace menu.

3. Enter 0.0052 for both the X and Y beam half-width.

This defines the beam at the object (input fiber end point), and since this posi-
tion is a beam waist, the wavefront is flat (radii of curvature set to zero as a 
shorthand way to define a flat wavefront, which is the default). 

Note:  Entering this value for both the X and Y beam half-width is not required, 
since CODE V by default assumes symmetry.
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4. On the Color Display tab, click the Display Gaussian Beam checkbox, and do 
not make any changes to the other settings.

Note that for very long systems, separate scale factors can be set for X and Y 
directions.
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5. Click OK.

The output (see the following figures) shows that the beam radius on the image 
surface is also 0.0052 mm, and that this is also a beam waist (beam waist dis-
tance is nearly zero). The wavefront radius at the image is -4.4352 mm.

Running CEF with Gaussian Beam Inputs
1. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu.

2. In the Fiber Coupling Efficiency dialog box on the Fiber Specs tab, set the 
Gaussian mode radius again to 0.0052

3. On the Beam Definition tab, click the Gaussian Beam button.
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4. Enter 0.0052 for both X and Y beam half-widths on the object surface, just as 
you did in the Gaussian Beam Trace option.

5. On the Computation tab, select the Decibel Scale button.

6. Click OK.

The insertion loss for this case is -0.0002 dB (essentially zero). This represents 
an idealized case of no clipping and no aberration. The element separation is 
small, so there is not much beam spreading. With these factors and with the 
beam radius and mode radius both equal to 0.0052 mm, you could expect nearly 
perfect coupling efficiency. But what happens with larger separations? 

7. In the LDM spreadsheet, change thickness of surface 2 to 100.
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8. Click the Execute button in the Fiber Coupling Efficiency window.

The new insertion loss value is -0.041 dB. Repeat steps 7 and 8 for 200 mm and 
300 mm separations and you will find the following results. These results are 
due only to beam spreading -- aperture clipping and aberration will also affect 
the results, but this is a good approximation for a lens that has little clipping and 
aberration. To see the effects of beam clipping, aberration and beam spreading, 
you need BPR.

Gaussian Effects in Optimization 
You can also include Gaussian beam-spreading effects when you optimize the 
coupling efficiency in Automatic Design. For example, if you know that the 
aspheric coupler will actually be used at 300 mm separation, you would like to find 
a focal distance (lens to output fiber) to provide better coupling than the -0.4 dB 
shown above. 

1. Make sure the air space is 300 mm (surface 2 thickness), then, in the LDM 
spreadsheet, right-click on the thickness of the Image and choose Vary from the 
shortcut menu (this is the defocus variable).

2. Choose the Optimization > Automatic Design menu and change the Error 
Function Type to Fiber Coupling Efficiency. Confirm that the Fiber Mode 
Radius value is 0.0052 mm (the default), and also check the Include Gaussian 
beam diffraction box as shown below. 

Separation, 
in mm

Gaussian Beam 
Insertion Loss

4.3632 -0.0002 dB

100 -0.0417 dB

200 -0.1831 dB

300 -0.4159 dB
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3. Click OK to run the optimization. 

The focal shift should be about 0.025 mm. If you now re-run the Fiber Coupling 
Efficiency calculation, you will see a coupling efficiency of about -0.12 dB. If you 
try this without checking the Include Gaussian beam diffraction box in 
optimization (reset the defocus to zero first), you will find only a slight 
improvement. This capability is useful whenever there are long propagation 
distances where beam spreading is an important effect. 

Note:  It may be more accurate to maintain symmetry between the input and output 
distances. To simulate this, freeze the image surface defocus (in the LDM 
spreadsheet, right-click and choose Freeze) and set it back to zero. Right-click on 
thickness 4 (the 4.3632 value) and choose Pickup, changing the pickup Surface to 
Object. Then, right-click on the object surface thickness and choose Vary. Re-run 
Automatic Design as described above. The new thickness value will be about 4.383, 
a shift of about 0.02 mm of both input and output fibers, and the Gaussian coupling 
efficiency will be -0.0002 dB, essentially perfect.
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Coupling Efficiency from Beam Propagation Method
We presented the method for saving BPR data in a buffer for use in CEF 
calculations in Chapter 2. Rather than repeat the explanation here, we will briefly 
summarize the steps without screen pictures. Please see Chapter 2 for more details 
on the procedure.

Calculating the Beam Propagation Results
1. In the LDM spreadsheet window, make sure the thickness of surface 2 is reset to 

the original value, 4.3632 mm.

2. In the Command Window, enter the command BUF DEL B1 to delete any 
previous contents of this buffer.

You will need to do this each time you run BPR, since BPR appends its data to 
the specified buffer rather than replacing it.

3. Choose the Analysis > Diffraction > FFT Beam Propagation menu.

4. On the Computation tab, change Start Surface to Object (End Surface should 
be Image).

5. On the Input Beam tab, select Gaussian Beam and change the beam half-
width to 0.0052 for both X and Y.

6. On the Output Controls tab, change Worksheet Buffer Output Quantity to 
Complex Amplitude, and set buffer number to 1 (or other if buffer 1 is in use).

7. Click OK.

Importing BPR Results into CEF
1. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu. The 

Fiber Coupling Efficiency dialog box is displayed.

2. On the Fiber Specs tab, change Gaussian mode radius to 0.0052.

3. On the Beam Definition tab, click Buffer Input and be sure the buffer number 
is 1 (or the value you used in BPR).

4. On the Computation tab, select the Decibel Scale checkbox.

Note:  A useful macro for this step, BUFDEL.seq, is available in the Macro 
dialog box, under Sample Macros - Utilities. By applying the macro to your 
toolbar, you will not have to remember the commands.
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5. Click OK.

6. If you repeat the above procedure for various separation values, you will find 
results as shown in the table below.

* The automatic propagation method changes at 200 mm in this case, from far 
field to near field, causing a slight change in numbers. To get the result shown, 
the propagation method was changed to far field on surface 2..3 
(DBP FFP S2..3). See “BPR - Diffraction-Based Beam Propagation” on 
page 19-37 in the CODE V Reference Manual for information on how 
propagators are chosen.

Assessing the Effect of Aperture Clipping
In the table below, we have repeated the BPR Insertion Loss column from the above 
table, and added two additional columns. The third column is calculated by the 
BPR-to-CEF procedure with oversized apertures (aperture radius of 1.5 mm on 
each surface, larger than the real lens in order to prevent any clipping by the 
apertures). The fourth column is repeated from the Gaussian Beam discussion 
above—this is the result of importing Gaussian Beam parameters into CEF, with no 
aperture or aberration information.

Tip:  When you import buffer data from BPR to CEF, you should not change 
FFT grid size or other grid parameters in CEF—these values are determined 
from the BPR data in the imported buffer.

Separation, 
in mm

BPR Insertion 
Loss

4.3632 -.06270 dB

100 -.09222 dB

200 -.1649 dB*

300 -.3157 dB
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* See the table footnote on page 98 for details about this propagation result.

What does this table tell us? With the exception of the short 4.6 mm separation, the 
correlation between the oversize aperture BPR case and the Gaussian beam case is 
extremely good. BPR results for each value in this case show final Fraction of 
Starting Energy of 1.0, which indicates that there is no aperture clipping. Since the 
lens is well corrected for spherical aberration (the only aberration in this on-axis 
monochromatic system), beam spreading should dominate. The short-separation 
case is really not inconsistent with this, since  -0.001494 dB insertion loss 
represents 99.97% coupling efficiency, pretty close to 100%.

What about the first BPR column? This should be the most accurate calculation 
since it includes aperture clipping. Note that aperture clipping hurts you for the 
shorter separations, but actually improves the insertion loss in the 200 and 300 mm 
cases compared to the no-clipping calculation. This shows that the effects of beam 
spreading, aberrations, and aperture clipping interact in complex ways.

Energy Considerations
When CEF reports a coupling efficiency of 0.98, it is reporting that 98% of the light 
incident on the output fiber is coupled into it. This says nothing about the 
efficiency with respect to the light input to the optical system.

One factor to consider when using BPR is the Fraction of Starting Energy value 
reported at each surface. This number reflects energy lost due to aperture clipping 
in the optical system, but it does not include all losses.

The Transmission Analysis option (TRA, Analysis > System > Transmission 
Analysis menu) includes surface losses (with or without coatings) as well as bulk 
transmission losses. For example, you can use the Surface Properties window to 
assign the glass characteristics of Schott SK2 to the “C0550” glass in this example, 
in order to define absorption properties (SK2 is close in index at 1550 nm but may 
not perform at all like C0550—this is just an illustrative example). Then, if you 

Separation, 
in mm

BPR Insertion 
Loss (True 
Apertures)

BPR Insertion 
Loss (Oversize 
Apertures)

Gaussian 
Beam 
Insertion Loss

4.3632 -.0627 dB -.00149 dB -0.0002 dB

100 -.092 dB -.047 dB -0.041 dB

200 -.165 dB * -.184 dB -0.183 dB 

300 -.316 dB -.418 dB -0.416 dB
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choose the Analysis > System > Transmission Analysis menu and click OK, you 
will find an average transmittance of 0.9661, which would directly multiply the 
(non-dB) coupling efficiency to estimate efficiency with respect to the input fiber.

Polarization
BPR does not include polarization effects, while the default (PSF) calculation of 
CEF does include them if you turn on polarization ray tracing (POL YES or Lens > 
Activate Polarization Ray Tracing menu). The Transmission Analysis option 
includes polarization effects in all cases, since this is needed to evaluate coating 
effects on transmission. If the main reason you would like polarization is for 
transmission calculation, the best combination is to use BPR and CEF for coupling 
efficiency, with TRA to calculate the transmission of the system up to the output 
fiber. 

If polarizaton is more fundamental (such as isolators that use birefringent crystals 
and Faraday rotators), then you cannot use BPR. In these instances, you must use 
CEF with POL YES, which will be reasonably accurate as long as there are no long 
free-space separations or multiple small clipping apertures. 

Conclusions
Coupling efficiency, or insertion loss, is a vital calculation for telecom systems. 
CODE V provides the tools to do a good job, but you must understand the 
interactions and limitations of the various components, especially the Beam 
Propagation and Fiber Coupling Efficiency (CEF) options. The following 
summarizes the coupling efficiency methods available in CODE V, along with their 
characteristics. These methods are defined in the Fiber Coupling Efficiency dialog 
box (Analysis > Diffraction menu), on the Beam Definition tab.

Ray Trace Lens System (with polarization ray trace inactive)

Point source approximation. CEF is calculated by overlap integral of PSF with 
output fiber mode profile. Does not include diffraction effects from clipping at 
multiple apertures, polarization effects, optical transmission, and truncation of 
beam.

Ray Trace Lens System (with polarization ray trace active)

Point source approximation. CEF is calculated by overlap integral of PSF with 
output fiber mode profile. Does not include diffraction effects from clipping at 
multiple apertures. Does include polarization effects, optical transmission 
(excluding bulk absorption) and truncation of the beam.
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Gaussian Beam Trace

Diagnostic tool to allow users to calculate coupling efficiency if a beam with 
specified characteristics (on object surface) were traced to the output fiber. CEF 
does this Gaussian beam trace internally. The Gaussian Beam Trace option (BEA) 
is often used to view specified Gaussian beam characteristics. It does not include 
clipping or aberrations other than astigmatism.

Buffer Input (complex amplitude from Beam Propagation)

A rigorous Gaussian beam propagation that includes the finite source size (no point 
source approximation), diffraction effects of multiple apertures, and lens 
aberrations. Insertion loss is calculated by the overlap integral of the complex 
amplitude of the beam (generated in Beam Propagation) with the mode profile of 
the output fiber. Beam Propagation is the most accurate method of calculating 
insertion loss in CODE V. Transmission effects including truncation (see BPR 
output), bulk absorption, and surface reflections are not included in the insertion 
loss calculation and must be calculated and added separately. Additionally, 
polarization effects are not currently handled by Beam Propagation.



102 CODE V Photonics Modeling Guide

Chapter 4 Coupling Efficiency Calculations



CODE V Photonics Modeling Guide  103

Chapter 5

Other Examples

This chapter shows other examples of photonics systems with brief explanations. 
Three of the examples are based on lens files supplied with CODE V. The fourth 
example is a multilayer coating for WDM applications, provided in command form.
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GRIN Lens Coupler
This example shows how to use catalog GRIN (gradient index) materials from NSG 
(http://www.nsgamerica.com) to set up a simple collimator followed by an identical 
element that re-focuses the light on a fiber. This is a common coupler configuration, 
and is similar in most respects to the aspheric coupler shown in the previous 
chapter.

To access the CODE V model for this system:

1. Choose the File > Open menu, and browse the lens subdirectory of the 
CODE V installation directory.

This will be something like C:\CODEV9xx\lens in a default installation.

2. Select the file grincoupler.len and click the Open button.

Things to Note
1. The lengths of the GRIN elements are kept equal by a pickup on the thickness of 

surface 3.

2. The lengths have been optimized for coupling efficiency, and are slightly 
different from the 4.80 mm quarter-pitch length listed for the SLW18 at 1300 
nm element on NSG’s Web site (http://www.nsgamerica.com/technology/
microlens.cfm). In practice, you would probably optimize the input fiber 
position rather than the lens length.

3. The SLW18 name designates a diameter of 1.8 mm, although the optical clear 
aperture is smaller than this (0.5 mm aperture radius is defined in the lens 
model). If you want to also model the mechanical size, you can define 
additional EDGE apertures on the surfaces (e.g., CIR s1 EDG 0.9).

4. There are some important restrictions in using BPR (beam propagation) with 
GRIN systems. Specifically, ray tracing must be used in spaces containing a 
GRIN material. Diffraction beam propagation (DBP) can be used for the non-
GRIN air spaces, but care must be taken to prevent conversion between 
wavefront and ray representations near a focus. See Appendix A for a 
discussion of this and other issues for GRIN modeling. Non-BPR coupling 

http://www.nsgamerica.com
http://www.nsgamerica.com/technology/microlens.cfm
http://www.nsgamerica.com/technology/microlens.cfm
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efficiency (CEF with ray tracing) can be used on GRIN systems without 
restrictions, but you must be careful of large air spaces as discussed in the last 
chapter, since Gaussian beam spreading is not modeled by the default CEF 
calculation.

Optical Isolator
The optical isolator shown below includes GRIN lenses, tilted surfaces, 
birefringent crystals, and a Faraday rotator. Its performance as an isolator depends 
on polarization and is determined by the size and position of the focused Gaussian 
beam coupled into the output fiber. Note that because it depends on polarization, 
this device cannot be analyzed with the BPR (beam propagation) option.

This model uses birefringent crystals and a 45° Faraday rotator to control the 
polarization state of forward and back-reflected beams. The crystal axes are set to 
-22.5° and +22.5° for the forward direction. This orientation works with the 
sandwiched Faraday rotator’s orientation, so that forward beams are passed with 
good efficiency (lower right PSF inset). When the reverse beam is traced, the 
polarization state is rotated so that the beam is split by the second crystal and little 
energy is coupled to the center (upper left PSF). This principle is used in various 
devices, but our sample is modeled after U.S. Pat. 5,208,876 (E-tek Dynamics).
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To access the CODE V model for this system:

1. Choose the File > Open menu, and browse the lens subdirectory of the 
CODE V installation directory.

This will be something like C:\CODEV9xx\lens in a default installation.

2. Select the file optiso.len and click the Open button.

Things to Note
1. This system uses the same SLW18 GRIN material as the first example in this 

chapter, but the elements have 8° alpha (ADE) tilts on the fiber-interface ends. 
This wedge angle helps to minimize back reflections.

2. The crystal and Faraday rotator materials are defined as Private Catalog glasses 
(choose the Display > List Lens Data > Private Catalog menu to see the index 
data).

3. Birefringent materials have directional index of refraction data, with two index 
values (no and ne) and a crystal axis direction that determine the paths of 
polarized light rays. The delta-index and crystal axis direction are defined in the 
Surface Properties window, Polarization page for surfaces with birefringent 
materials.

4. The Faraday Rotator is one of three ideal “polarization operators” that can be 
attached to a surface (the others are linear polarizers and retarders). See the 
CODE V Reference Manual for more information on polarization issues.

Reversing the Lens
Although this model can be used to model both the forward and reverse beam paths, 
the lens is not actually traced backwards. Instead, you must modify the crystal axis 
directions of the birefringent crystals to simulate what the beam “sees” in traversing 
the system in each direction.

The supplied lens is set up for the forward simulation. Here is the procedure to 
analyze and reverse it.

1. Confirm that the menu item Lens > Activate Polarization Ray Tracing has a 
check mark next to it.

2. Choose the Analysis > Diffraction > Point Spread Function menu, and on the 
Normalization tab, select Decibels as the PSF output mode. Then, on the Color 
Display tab, select the Color Display checkbox. Click OK.

You should get a single circular PSF distribution (you can suppress the list and 
PSF Plot displays on the Output Controls tab if you wish, or just ignore them). 
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This circular beam is right on the Z axis and will give fairly good coupling 
efficiency.

3. Choose the Analysis > Diffraction > Fiber Coupling Efficiency menu and set 
the Gaussian mode radius to 0.005 mm, choose Decibel Scale on the 
Computation tab, and click OK.

You should get about -0.62 dB.

4. In the LDM window, right-click on surface 5 “Crystal-1,” choose Surface 
Properties from the shortcut menu, and select the Birefringent Materialspage.

5. Change the Crystal Axis Orientation Angle to +22.5 degrees (i.e., change its 
sign)

6. Use the surface selector to go to Surface 10 “Crystal-2” and change the Crystal 
Axis Orientation Angle to -22.5 degrees (i.e., change its sign as well).

Note that by changing the signs of the crystal axis for the two birefringent crys-
tals, you are simulating the situation that the reverse beam sees (plus, then 
minus) which is opposite the forward case (minus, then plus).

7. Click the Execute/Recalculate buttons in the Point Spread Function and Fiber 
Coupling Efficiency output windows to re-run the calculations.

You should see the split PSF as shown above, and the coupling efficiency 
should be around -18.5 dB. Note that with polarization, the CEF output includes 
additional information on polarization contrast and loss, so the coupling effi-
ciency value will not be the last dB item in the text output (check the labels on 
the output to make sure you are using the right values). You may want to change 
the lens title to include REVERSE and save the lens in a separate file name such 
as optisoREV.len, to avoid confusion.
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Note that the reverse direction insertion loss of -18.5 dB assumes that 100% of 
the energy is reflected from the output fiber. In reality, a typical Fresnel reflec-
tion from this fiber would be only about 4%, so total insertion loss in the reverse 
direction is -33.5 dB.

Free Space Optical Interconnect 
This example is modeled after a design by Zheng, Marchand et al in Appl. Opt., 38, 
5632 (1999) for optical computing applications. The source is a linear array of 12 
VCSELs operating at 850 nm on one side of the optical axis. The receiver is a linear 
array of 12 detectors on the other side of the axis. The detectors are 80 microns 
square.

To access the CODE V model for this system:

1. Choose the File > Open menu and browse the lens subdirectory of the CODE V 
installation directory.

2. Select the file optinterconnect.len and click the Open button.

Free space optical interconnect

10.00   MM   

Mirror

Lens
Substrate

Linear array

Linear array

of detectors

of VCSELs
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Things to Note
1. The lens model is set up as a sequential double-pass system with pickups to link 

together identical surfaces.

2. The telecentric flag (TEL YES, found on the Pupil page of the System Data 
window; Lens > System Data menu) is used to keep the entering chief rays 
from all fields parallel to the Z axis.

3. Although VCSEL’s are specified, there is no special model for these in 
CODE V—they are represented simply as object points with proper positioning 
(System Data). Similar to fibers, lasers have an output intensity distribution that 
is approximately Gaussian, and this is modeled with Pupil Apodization. Some 
lasers have significant inherent astigmatism, and this can be modeled with the 
Astigmatic Object feature, also found under System Data (not used in this 
example).
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WDM Multilayer Coating
The figure below is the spectral transmission of a narrow bandpass filter for 200 
Ghz channel spacing WDM. It is a many-layer stack with high and low index 
materials of Ta2O5 and SiO2, respectively. Results are shown for normal incidence 
(this dB plot was created with the User Graphics option, UGR). The shift of the 
bandpass with respect to angle of incidence is about .2 nm/degree. This analysis 
was based on a design description in “High-Performance Filters for Dense 
Wavelength Division Multiplex Fiber Optic Communications,” by J. J. Pan of E-tek 
Dynamics, Inc. (subsequently acquired by JDS Uniphase Corporation; see 
http://www.jdsu.com).

The command sequence that follows runs the CODE V MUL option to create a 
narrow-band (wavelength selective) WDM filter of known prescription (i.e., we are 
simply entering known coating parameters, not designing the coating to a specific 
target, though MUL also has this capability). The MUL option can analyze the 
reflectance and transmittance properties of such coatings, independent of any lens 

Note:  The Multilayer Coating option (MUL) is not available in the GUI; it must be 
run on the command line (Command Window) or as a macro. A macro to set up this 
filter (wdmfilter.seq) and another to attach it to a tunable filter lens model 
(tunable_filter.seq) are available on ORA’s Customer Support Web site,
http://www.oraservice.com. Click the CODE V Support link on the main page and 
click on the Macro Downloads link.

Narrow bandpass filter for 

200 Ghz channel spacing WDM
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or optical system. If you save such a coating as a file, you can also attach the 
coating to a surface of a CODE V optical system model, in order to include the 
effects of the coating on transmission, polarization, and diffraction performance 
(including coupling efficiency).

In this model, we use macro variables to enter the index of refraction of the high-
index (^h) and low-index materials (^l), making it easy to change later. Since 
coatings typically have repetitive structures, we also define several groups (GRO) 
of coating layers, giving each group a letter name. Defining a group of layers both 
enters the layers AND defines the letter name for later re-entry by name alone. The 
individual coating layers are defined with a COA command, which has the 
following format:

COA thickness control_code index [extinction_coefficient]

where thickness is expressed in fractions of the reference wavelength (in this case 
1537.2 nm, the calculated center of the entered wavelength range), control_code is 
used for optimization (100 means frozen, 0 means variable, if we were to use MAU 
to optimize the coating), index is the index of refraction of the layer, and 
[extinction_coefficient] is the optional “imaginary part” of the complex index of 
refraction (if it is non-zero, the material will exhibit absorption as well as 
reflectance and transmittance).

The sequence ends with commands to print, analyze, plot, and save this multilayer 
coating design in a text file (WDMFILTER.MUL). The CODE V Reference Manual 
has much more information and more examples of multilayer coating designs.
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! WDMFILTER.SEQ
^H == 2.05     ! high index
^L == 1.44658  ! low index

MUL
MDA   ! MUL data

 TIT '200 GHZ WDM FILTER'
 WLG 1542 1552 .2  ! wavelengths
 ANG 0     ! Angle of incidence

 REF 1547  ! reference WL

GRO 'A'
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L

END
GRO 'B'

  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H
  COA .25 100 ^L
  COA .25 100 ^H

END

GRO 'C'
  COA .25 100 ^L
  COA .25 100 ^L
  COA .25 100 ^L
  COA .25 100 ^L

END

GRO 'D'
  COA .25 100 ^H
  COA .25 100 ^L

END

GRO 'E'
  COA .25 100 ^L
  COA .25 100 ^H

END      ! continues next column...

COA 'A'
COA 'D'
COA 'C'
COA 'E'

COA 'B'
COA .25 100 ^L

COA 'A'
COA 'D'

COA .25 100 ^H
COA 'C'

COA .25 100 ^H

COA 'B'
COA 'E'

COA .25 100 ^L

COA 'A'
COA 'D'

COA 'D'
COA 'C'
COA 'E'

COA 'B'
COA 'E'

COA .25 100 ^L

COA 'A'

COA 'D'
COA 'C'

COA .25 100 ^L
COA .25 100 ^L

COA 'E'

COA 'B'
COA 'E'

COA .25 100 ^L
SUB 1.52     ! substrate index

END

MPR   ! mul-print

MAN   ! mul-analyze
GO

MPL   ! mul-plot
 TRN  ! (transmission)

GO
SAV WDMFILTER

CAN  ! cancel (exit) MUL option
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Appendix A

Analyzing Systems with 
GRIN Materials

This appendix presents a short list of considerations when modeling and analyzing 
photonic systems that contain gradient index (GRIN) materials. 

Contents

Defining GRIN materials ......................................................................................114

GRIN Material Coordinate System.......................................................................115

Apertures Near Beam Waists ................................................................................116

Considerations When Using Beam Propagation...................................................117
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Defining GRIN materials
CODE V contains several catalog GRIN materials available from Nippon Sheet 
Glass Company (NSG), LightPath Technologies, and Gradient Lens Corporation. 
The table below lists these catalog glasses.

The NSG glass names can be specified in the Glass column of the LDM 
spreadsheet. The LightPath and GLC materials require some additional information 
and are defined as “Private Catalog” materials. See “GLC (Gradient Lens 
Corporation) Catalog in CODE V” on page 5-66 in the CODE V Reference Manual 
for details.

In addition, CODE V supports several GRIN dispersion equation forms that allow 
you to create a private-catalog material for any GRIN material for which you have 
refractive index profile data.

NSG LightPath 
Technologies

Gradient Lens 
Corporation (GLC)

SLA20 G14SFP EG10

SLA12 G14SFN EG20

SLA09 G23SFP EG27

SLA06 G23SFN EG31

SLN20 G32SFP

SLS10 G32SFN

SLS20 G41SFP

SLW10 G41SFN

SLW18 G51SFP

SLW20 G51SFN

SLH18 G4LAKP

SLW30 G4LAKN

SLW40

SLC18
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GRIN Material Coordinate System
Unlike homogeneous materials, the refractive index of GRIN materials varies as a 
function of location within the material. Thus, GRIN material properties are 
defined with respect to an X, Y, and Z coordinate system.

By default, the coordinate system of the GRIN assigned to a surface (Sk) is 
coincident with the local coordinate system following Sk. Usually, this means that 
the GRIN axes are the same as the surface’s local axes. However, if a Decenter & 
Return decenter type is chosen for Sk, the GRIN axes will be aligned to the original 
coordinate system before the decenter. This feature allows easy modeling of GRIN 
elements with wedged faces, where the gradient index axes is not the same as the 
wedged face.

In addition, CODE V supports a global surface reference for the GRIN coordinate 
system. This control is found on the Gradient Index page in the Surface 
Properties window, shown below.

This feature allows you to associate the GRIN coordinate system with the 
coordinate system of an arbitrary surface before the GRIN surface. Defined this 
way, it is very easy to manipulate the GRIN coordinate axes without changing the 
model geometry. It can be very useful for tolerance studies associated with GRIN 
materials.
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Apertures Near Beam Waists
This consideration is not exclusively related to the use of GRIN materials, but 
often, systems with GRIN materials have surfaces very close to beam caustics or 
beam waists. Remember that unless overridden, CODE V will define default 
apertures on every non-dummy surface in the model using five reference rays. For 
surfaces near beam caustics or beam waists, these apertures are generally 
undersized. It is very important for users to know what apertures CODE V is using 
(for any system).   The Apertures Used control is available on the System Settings 
page of the System Data window, shown below, and can also be made a Status Bar 
item.

If necessary, set user-defined apertures in your model and change the Apertures 
Used control to User-Defined Only.
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Considerations When Using Beam Propagation
Currently, diffraction beam propagation can be done only through a homogenous 
media. If your system has GRIN materials, you must use ray tracing through the 
GRIN. This may require converting between wave fronts and rays as the beam 
propagates through the system. The method is to beam propagate to the GRIN, 
convert to rays and ray trace through the GRIN, and then convert to a wave front 
and beam propagate after the GRIN. In order to get accurate results, it is important 
that the conversion between wave fronts and rays always be done in the far field 
(i.e., away from a beam waist). 

If the GRIN surface is close to a beam waist, you must follow the steps below. 
Following this procedure will ensure that the conversion between rays and wave 
fronts is handled as accurately as possible:

1. Add a dummy surface in the far field relative to the beam waist (5 to 10 mm 
away is usually sufficient). 

2. Set the thickness of this dummy surface so that the next surface is the front 
face of the GRIN (i.e., usually a negative thickness)

3. Set the propagation method controls on the Computation tab of the FFT 
Beam Propagation dialog box (Analysis > Diffraction menu) so that beam 
propagation is used up to the dummy surface. Ray tracing will be used back to 
the GRIN and then through the GRIN material.
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4. Insert additional dummy surfaces as required to avoid converting between rays 
and wave fronts near beam caustics or beam waists.

5. Be sure that the beam propagation surface range includes propagating (not ray 
tracing) to the final (image) surface. 
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